[bug#72700] gnu: Remove an unnecessary test timeout for at-spi2-core
Commit Message
aarch64 builds keep failing because of this timeout, so removing this
timeout should help
---
gnu/packages/gtk.scm | 4 ++++
1 file changed, 4 insertions(+)
Comments
Thanks! Pushed as 58a839273d1e4fac2b3a0ec456aabdf82deaa124.
I tweaked the commit message to fit our norms, which mostly match
the GNU ‘changelog’ style:
gnu: at-spi2-core: Remove unnecessary test timeout.
[Free-form blurb goes here, if you want, but more often than
not
future readers are better served by a succinct code comment.]
* gnu/packages/gtk.scm (at-spi2-core)[arguments]: Remove the
‘timeout’ argument from the test invocation.
Closing,
T G-R
@@ -856,6 +856,10 @@ (define-public at-spi2-core
(with-directory-excursion (string-append "../at-spi2-core-"
#$version "")
(invoke "dbus-run-session" "--" "ci/run-registryd-tests.sh")
+ ;; Remove test timeout which caused failed builds on
+ ;; aarch64
+ (substitute* "tests/atspi/meson.build"
+ ((", timeout: [0-9]+") ""))
(substitute* "ci/run-tests.sh"
(("ps auxwww") "") ;avoid a dependency on procps
(("meson test -C _build")