diff mbox series

[bug#72512] gnu: nheko: Add xdg-utils to dependencies.

Message ID 20240807124202.31855-1-mcsinyx@disroot.org
State New
Headers show
Series [bug#72512] gnu: nheko: Add xdg-utils to dependencies. | expand

Commit Message

ashish.is--- via Guix-patches" via Aug. 7, 2024, 12:42 p.m. UTC
Nheko uses QDesktopServices::openUrl, which prefers xdg-open
before follow less standard heuristics to find the default browser.

* gnu/packages/messaging.scm (nheko)[inputs]: Add xdg-utils.

Change-Id: Id9e2e0e0f2372c457f08b065de2d2528620f6ec5
---
 gnu/packages/messaging.scm | 2 ++
 1 file changed, 2 insertions(+)

Comments

Christopher Baines Aug. 11, 2024, 10:37 a.m. UTC | #1
guix-patches--- via <guix-patches@gnu.org> writes:

> Nheko uses QDesktopServices::openUrl, which prefers xdg-open
> before follow less standard heuristics to find the default browser.
>
> * gnu/packages/messaging.scm (nheko)[inputs]: Add xdg-utils.
>
> Change-Id: Id9e2e0e0f2372c457f08b065de2d2528620f6ec5
> ---
>  gnu/packages/messaging.scm | 2 ++
>  1 file changed, 2 insertions(+)

Sounds good to me, I've pushed this to master as
671da915099a552c23b728fc45580530060607ce.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index fb80866791a5..9cf278549e92 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -44,6 +44,7 @@ 
 ;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
 ;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
 ;;; Copyright © 2024 Igor Goryachev <igor@goryachev.org>
+;;; Copyright © 2024 Nguyễn Gia Phong <mcsinyx@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2538,6 +2539,7 @@  (define-public nheko
            spdlog
            vulkan-headers
            vulkan-loader
+           xdg-utils                    ; xdg-open for opening URLs
            zlib))
     (native-inputs
      (list asciidoc pkg-config qttools))