diff mbox series

[bug#72471,07/24] gnu: nnpack: Depend on python-peachpy only for x86_64.

Message ID 20240804221635.3805-7-david.elsing@posteo.net
State New
Headers show
Series Update PyTorch and dependencies | expand

Commit Message

David Elsing Aug. 4, 2024, 10:15 p.m. UTC
* gnu/packages/machine-learning.scm (nnpack)[native-inputs]: Provide
python-peachpy only when 'target-x86-64?'.
---
 gnu/packages/machine-learning.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 418bfb5d03..99f0185942 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -4045,7 +4045,9 @@  (define-public nnpack
              pthreadpool
              googletest))
       (native-inputs
-       (list python python-peachpy python-six))
+       `(,python
+         ,@(if (target-x86-64?) (list python-peachpy) '())
+         ,python-six))
       ;; Supported for Linux.
       (supported-systems '("x86_64-linux" "armhf-linux" "aarch64-linux"))
       (license license:bsd-2))))