diff mbox series

[bug#72471,06/24] gnu: cpuinfo: Update to commit 05332fd.

Message ID 20240804221635.3805-6-david.elsing@posteo.net
State New
Headers show
Series Update PyTorch and dependencies | expand

Commit Message

David Elsing Aug. 4, 2024, 10:15 p.m. UTC
Also disable tests on aarch64, because they fail in the build container.

* gnu/packages/parallel.scm (cpuinfo): Update to commit 05332fd.
[arguments]<#:tests?>: Disable on aarch64.
[supported-systems]: Remove field.
---
 gnu/packages/parallel.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index ca1e92963a..9be6e993e7 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -519,7 +519,7 @@  (define-public cpuinfo
   ;; There's currently no tag on this repo.
   (let ((version "0.0")
         (revision "3")
-        (commit "aa4b2163b99ac9534194520f70b93eeefb0b3b4e"))
+        (commit "05332fd802d9109a2a151ec32154b107c1e5caf9"))
     (package
       (name "cpuinfo")
       (version (git-version version revision commit))
@@ -530,10 +530,13 @@  (define-public cpuinfo
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "12x4krkyzxngf1l2ck33lnsp8pyzf6gyjj9mp9cnka9mw3h6617m"))))
+                  "0w0kfc1fn9viirkhbr8dgfy9m5clfsg3k9p6kdxhzqpyjhgd252n"))))
       (build-system cmake-build-system)
       (arguments
        (list
+        ;; cpuinfo does not work in the build container for aarch64:
+        ;; https://github.com/pytorch/cpuinfo/issues/143
+        #:tests? (not (target-aarch64?))
         #:configure-flags
         '(list "-DBUILD_SHARED_LIBS=ON"
                "-DUSE_SYSTEM_LIBS=ON")
@@ -552,9 +555,6 @@  (define-public cpuinfo
        "The cpuinfo library provides a C/C++ and a command-line interface to
 obtain information about the CPU being used: supported instruction set,
 processor name, cache information, and topology information.")
-      ;; On aarch64-linux, there is a bug reported upstream:
-      ;; https://github.com/pytorch/cpuinfo/issues/14
-      (supported-systems '("armhf-linux" "i686-linux" "x86_64-linux"))
       (license license:bsd-2))))
 
 (define-public clog