diff mbox series

[bug#72471,03/24] gnu: python-optree: Update to 0.11.0.

Message ID 20240804221635.3805-3-david.elsing@posteo.net
State New
Headers show
Series Update PyTorch and dependencies | expand

Commit Message

David Elsing Aug. 4, 2024, 10:15 p.m. UTC
* gnu/packages/python-xyz.scm (python-optree): Update to 0.11.0.
[arguments]<#:test-flags>: Disable failing test.
---
 gnu/packages/python-xyz.scm | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ce33b330a3..ae34bd7dcb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12300,7 +12300,7 @@  (define-public python-treelib
 (define-public python-optree
   (package
     (name "python-optree")
-    (version "0.10.0")
+    (version "0.11.0")
     (source
      (origin
        (method git-fetch)
@@ -12310,9 +12310,14 @@  (define-public python-optree
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1q3wljk7cyl5rsam02sfsj8zjrqx4c3x9vic8j6xx13p8czpsisg"))
+         "0sk5lm1xyxi7z0yjckip77qvbidyb7i1znmn9fz96q74hl9ffyan"))
        (patches (search-patches "python-optree-fix-32-bit.patch"))))
     (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:test-flags
+      ;; This test fails due to a circular import
+      ''("-k" "not test_treespec_pickle_missing_registration")))
     (propagated-inputs (list python-typing-extensions))
     (native-inputs
      (list python-pytest