diff mbox series

[bug#72471,15/24] gnu: Remove onnx-for-torch2.

Message ID 20240804221635.3805-15-david.elsing@posteo.net
State New
Headers show
Series Update PyTorch and dependencies | expand

Commit Message

David Elsing Aug. 4, 2024, 10:15 p.m. UTC
* gnu/packages/machine-learning.scm (onnx-for-torch2): Delete variable.
---
 gnu/packages/machine-learning.scm | 29 -----------------------------
 1 file changed, 29 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index b9a128dd1b..b1b11b5410 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1417,35 +1417,6 @@  (define args
 operators and standard data types.")
     (license license:expat)))
 
-(define-public onnx-for-torch2
-  (package
-    (inherit onnx)
-    (name "onnx")
-    (version "1.13.1")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/onnx/onnx")
-                    (commit (string-append "v" version))))
-              (sha256
-               (base32
-                "16967dbq2j40diqd0s37r19llsab8q8vbxkg1ppgy0p9fpdhfhyp"))
-              (file-name (git-file-name name version))
-              (patches (search-patches "onnx-1.13.1-use-system-googletest.patch"
-                                       "onnx-shared-libraries.patch"))
-              (modules '((guix build utils)))
-              (snippet
-               '(begin
-                  (delete-file-recursively "third_party")
-                  (substitute* "onnx/backend/test/runner/__init__.py"
-                    (("urlretrieve\\(.*") "raise unittest.SkipTest('Skipping download')\n"))))))
-    (arguments
-     ;; reuse build system tweaks
-     (substitute-keyword-arguments (package-arguments onnx)
-       ((#:phases phases)
-        #~(modify-phases #$phases
-            (delete 'relax-requirements)))))))
-
 (define-public python-onnx
   ;; This used to be called "python-onnx" because it provided nothing but
   ;; Python bindings.  The package now provides shared libraries and C++