diff mbox series

[bug#72471,12/24] gnu: python-nbval: Update to 0.11.0.

Message ID 20240804221635.3805-12-david.elsing@posteo.net
State New
Headers show
Series Update PyTorch and dependencies | expand

Commit Message

David Elsing Aug. 4, 2024, 10:15 p.m. UTC
* gnu/packages/python-check.scm (python-nbval): Update to 0.11.0.
[arguments]<#:phases>: Adjust 'check' phase.
[native-inputs]: Remove python-pytest.
[propagated-inputs]: Add python-coverage and python-pytest.  Remove
python-six.
---
 gnu/packages/python-check.scm | 27 +++++++++++----------------
 1 file changed, 11 insertions(+), 16 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 74e833686f..6b42d3c45c 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1585,13 +1585,13 @@  (define-public python-nbmake
 (define-public python-nbval
   (package
     (name "python-nbval")
-    (version "0.9.6")
+    (version "0.11.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "nbval" version))
        (sha256
-        (base32 "0h3xrnw0mj1srigrx2rfnd73h8s0xjycclmjs0vx7qkfyqpcvvyg"))))
+        (base32 "154h6xpf9h6spgg3ax6k79fd40j197ipwnfjmf5rc2kvc2bmgjbp"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -1605,21 +1605,16 @@  (define-public python-nbval
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
-               (invoke "pytest" "-vv" "-k"
-                       (string-append
-                        ;; This only works with Pytest < 5.
-                        "not nbdime_reporter"
-                        ;; https://github.com/computationalmodelling/nbval/pull/148.
-                        " and not test_timeouts"
-                        ;; It seems the output format has changed; the following
-                        ;; test fails with "Unexpected output fields from
-                        ;; running code: {'text/plain'}".
-                        " and not test_conf_ignore_stderr "))))))))
-    (native-inputs
-     (list python-pytest python-pytest-cov python-sympy))
+               (invoke "pytest" "-vv"
+                       ;; nbdime forms a dependency cycle
+                       "--ignore=tests/test_nbdime_reporter.py")))))))
+    (native-inputs (list python-pytest-cov python-sympy))
     (propagated-inputs
-     (list python-ipykernel python-jupyter-client python-nbformat
-           python-six))
+     (list python-coverage
+           python-ipykernel
+           python-jupyter-client
+           python-nbformat
+           python-pytest))
     (home-page "https://github.com/computationalmodelling/nbval")
     (synopsis "Pytest plugin to validate Jupyter notebooks")
     (description