@@ -25937,6 +25937,32 @@ (define-public python-setuptools-rust
Rust Python extensions implemented with @code{PyO3} or @code{rust-cpython}.")
(license license:expat)))
+(define-public python-pyclibrary
+ (package
+ (name "python-pyclibrary")
+ (version "0.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/MatthieuDartiailh/pyclibrary")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0scnfk0dr8za1m7k1ml74dr8sg570sgs3hmis7fl27s2h1dbsapk"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f)) ; XXX: 1/3rd of tests are failing, find out why.
+ (native-inputs (list python-pytest))
+ (propagated-inputs (list python-pyparsing-2.4.7))
+ (home-page "http://github.com/MatthieuDartiailh/pyclibrary")
+ (synopsis "Wrap dynamic libraries in Python")
+ (description "This package provides a library to make wrapping dynamic
+libraries in Python less cumbersome and more user friendly. It includes a
+pure-Python C parser and an automation library that uses C header file
+definitions to simplify the use of C bindings.")
+ (license license:expat)))
+
(define-public python-pyclipper
(package
(name "python-pyclipper")