diff mbox series

[bug#72415] gnu: mpich: Update to 4.2.2.

Message ID 20240802075740.14138-1-romain.garbage@inria.fr
State New
Headers show
Series [bug#72415] gnu: mpich: Update to 4.2.2. | expand

Commit Message

Romain GARBAGE Aug. 2, 2024, 7:57 a.m. UTC
* gnu/packages/mpi.scm (mpich): Update to 4.2.2. Add new dependency.

Change-Id: I9f3e42cb58c399a89835ac38dcfdd9dd11efe210
---
 gnu/packages/mpi.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)


base-commit: 2aa0127d4e3d2363c04caab88137b070b6cf1318

Comments

Zheng Junjie Aug. 3, 2024, 2:44 a.m. UTC | #1
Romain GARBAGE <romain.garbage@inria.fr> writes:

> * gnu/packages/mpi.scm (mpich): Update to 4.2.2. Add new dependency.

* gnu/packages/mpi.scm (mpich): Update to 4.2.2
[native-inputs]: Add python-minimal.

>
> Change-Id: I9f3e42cb58c399a89835ac38dcfdd9dd11efe210
> ---
>  gnu/packages/mpi.scm | 7 ++++---
>  1 file changed, 4 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
> index 4c18da30ef..08ec9c9053 100644
> --- a/gnu/packages/mpi.scm
> +++ b/gnu/packages/mpi.scm
> @@ -43,6 +43,7 @@ (define-module (gnu packages mpi)
>    #:use-module (gnu packages libevent)
>    #:use-module (gnu packages linux)
>    #:use-module (gnu packages pciutils)
> +  #:use-module (gnu packages python)
>    #:use-module (gnu packages xorg)
>    #:use-module (gnu packages gtk)
>    #:use-module (gnu packages xml)
> @@ -450,14 +451,14 @@ (define-public python-mpi4py
>  (define-public mpich
>    (package
>      (name "mpich")
> -    (version "3.3.2")
> +    (version "4.2.2")
>      (source (origin
>                (method url-fetch)
>                (uri (string-append "http://www.mpich.org/static/downloads/"
>                                    version "/mpich-" version ".tar.gz"))
>                (sha256
>                 (base32
> -                "1farz5zfx4cd0c3a0wb9pgfypzw0xxql1j1294z1sxslga1ziyjb"))))
> +                "0h8xg1wi2d88hnfmj3xydf1hj78r7fh05jljhk5jgxmbmsrmngw8"))))
>      (build-system gnu-build-system)
>      (inputs
>       `(,zlib
> @@ -468,7 +469,7 @@ (define-public mpich
>               (list ucx)
>               '())))
>      (native-inputs
> -     (list perl which gfortran))
> +     (list perl which gfortran python))

maybe python-minimal?

>      (outputs '("out" "debug"))
>      (arguments
>       `(#:configure-flags
>
> base-commit: 2aa0127d4e3d2363c04caab88137b070b6cf1318
diff mbox series

Patch

diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 4c18da30ef..08ec9c9053 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -43,6 +43,7 @@  (define-module (gnu packages mpi)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages pciutils)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages xml)
@@ -450,14 +451,14 @@  (define-public python-mpi4py
 (define-public mpich
   (package
     (name "mpich")
-    (version "3.3.2")
+    (version "4.2.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://www.mpich.org/static/downloads/"
                                   version "/mpich-" version ".tar.gz"))
               (sha256
                (base32
-                "1farz5zfx4cd0c3a0wb9pgfypzw0xxql1j1294z1sxslga1ziyjb"))))
+                "0h8xg1wi2d88hnfmj3xydf1hj78r7fh05jljhk5jgxmbmsrmngw8"))))
     (build-system gnu-build-system)
     (inputs
      `(,zlib
@@ -468,7 +469,7 @@  (define-public mpich
              (list ucx)
              '())))
     (native-inputs
-     (list perl which gfortran))
+     (list perl which gfortran python))
     (outputs '("out" "debug"))
     (arguments
      `(#:configure-flags