[bug#72071,2/2] Skip test_check_version since the patch-settings phase needs to modify the test reference file.

Message ID 20240729173604.220603-3-luca.cirrottola@inria.fr
State New
Headers
Series A clean series of patches |

Commit Message

Luca Cirrottola July 29, 2024, 5:36 p.m. UTC
  ---
 gnu/packages/maths.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)
  

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 8116569bca..4e69fb1eb9 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1728,7 +1728,12 @@  (define-public hdf5-1.8
              (substitute* "hl/fortran/src/Makefile.in"
                (("libhdf5hl_fortran_la_LDFLAGS =")
                 (string-append "libhdf5hl_fortran_la_LDFLAGS = -Wl,-rpath="
-                               (assoc-ref outputs "fortran") "/lib")))))
+                               (assoc-ref outputs "fortran") "/lib")))
+             ;; Skip test_check_version since the "patch-settings" phase
+             ;; will modify the test reference.
+             (substitute* "test/test_check_version.sh.in"
+              (("TESTING\\(\\).*" all)
+               (string-append all "\nSKIP; exit 0\n")))))
          (add-after 'configure 'patch-settings
            (lambda _
              ;; libhdf5.settings contains the full path of the