[bug#72071,2/2] Skip test_check_version since the patch-settings phase needs to modify the test reference file.
Commit Message
---
gnu/packages/maths.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
@@ -1728,7 +1728,12 @@ (define-public hdf5-1.8
(substitute* "hl/fortran/src/Makefile.in"
(("libhdf5hl_fortran_la_LDFLAGS =")
(string-append "libhdf5hl_fortran_la_LDFLAGS = -Wl,-rpath="
- (assoc-ref outputs "fortran") "/lib")))))
+ (assoc-ref outputs "fortran") "/lib")))
+ ;; Skip test_check_version since the "patch-settings" phase
+ ;; will modify the test reference.
+ (substitute* "test/test_check_version.sh.in"
+ (("TESTING\\(\\).*" all)
+ (string-append all "\nSKIP; exit 0\n")))))
(add-after 'configure 'patch-settings
(lambda _
;; libhdf5.settings contains the full path of the