[bug#72322] gnu: Add go-github-com-anaskhan96-soup.
Commit Message
* gnu/packages/golang-web.scm (go-github-com-anaskhan96-soup): New variable.
---
gnu/packages/golang-web.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
Comments
Hi,
Thank you for the patch.
Pushed as fb2347f6d1 to master.
--
Oleg
@@ -190,6 +190,33 @@ (define-public go-github-com-andybalholm-cascadia
the parse trees produced by the html package.")
(license license:bsd-2)))
+(define-public go-github-com-anaskhan96-soup
+ (package
+ (name "go-github-com-anaskhan96-soup")
+ (version "1.2.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/anaskhan96/soup")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0s19119sy4zqf05sgpdymcbdaz5bg86n7xwgd2m1vvxjmp485k5p"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/anaskhan96/soup"))
+ (native-inputs
+ (list go-golang-org-x-net))
+ (inputs
+ ;; needed for the check phase
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/anaskhan96/soup")
+ (synopsis "Web Scraper in Go, similar to BeautifulSoup")
+ (description "Small web scraper package for Go, with its interface
+highly similar to that of BeautifulSoup.")
+ (license license:expat)))
+
(define-public go-github-com-audriusbutkevicius-pfilter
(package
(name "go-github-com-audriusbutkevicius-pfilter")