[bug#72062,v3,3/5] gnu: slurm: Add PMIx support.
Commit Message
* gnu/packages/parallel.scm (slurm) [inputs]: Add dependency.
[arguments]: Update configure flags.
Change-Id: I6544be5eb44980191d0788738ab960263c56c0ba
---
gnu/packages/parallel.scm | 4 ++++
1 file changed, 4 insertions(+)
@@ -229,6 +229,7 @@ (define-public slurm
`(,hwloc-2 "lib")
json-c
linux-pam
+ openpmix
munge
numactl
readline))
@@ -245,6 +246,9 @@ (define-public slurm
(string-append "--with-json=" #$(this-package-input "json-c"))
(string-append "--with-munge=" #$(this-package-input "munge"))
+ ;; Use PMIx bundled with Open MPI (this is required for Open MPI 5.x).
+ (string-append "--with-pmix=" #$(this-package-input "openpmix"))
+
;; 32-bit support is marked as deprecated and needs to be
;; explicitly enabled.
#$@(if (target-64bit?) '() '("--enable-deprecated")))