diff mbox series

[bug#72062,v3,3/5] gnu: slurm: Add PMIx support.

Message ID 20240712120140.20391-4-romain.garbage@inria.fr
State New
Headers show
Series Add OpenMPI 5.x. | expand

Commit Message

Romain GARBAGE July 12, 2024, noon UTC
* gnu/packages/parallel.scm (slurm) [inputs]: Add dependency.
[arguments]: Update configure flags.

Change-Id: I6544be5eb44980191d0788738ab960263c56c0ba
---
 gnu/packages/parallel.scm | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index f173d1b75e..694968b727 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -229,6 +229,7 @@  (define-public slurm
                   `(,hwloc-2 "lib")
                   json-c
                   linux-pam
+                  openpmix
                   munge
                   numactl
                   readline))
@@ -245,6 +246,9 @@  (define-public slurm
                    (string-append "--with-json=" #$(this-package-input "json-c"))
                    (string-append "--with-munge=" #$(this-package-input "munge"))
 
+                   ;; Use PMIx bundled with Open MPI (this is required for Open MPI 5.x).
+                   (string-append "--with-pmix=" #$(this-package-input "openpmix"))
+
                    ;; 32-bit support is marked as deprecated and needs to be
                    ;; explicitly enabled.
                    #$@(if (target-64bit?) '() '("--enable-deprecated")))