diff mbox series

[bug#72071,2/2] Fix broken HDF5 test: Do not modify the file src/libhdf5.settings generated by the configure script, as it will be checked against a new version generated by the test code in test/test_check_version.sh.in.

Message ID 20240712094900.15964-2-luca.cirrottola@inria.fr
State New
Headers show
Series Fix hdf5-parallel-openmpi | expand

Commit Message

Luca Cirrottola July 12, 2024, 9:49 a.m. UTC
---
 gnu/packages/maths.scm | 13 -------------
 1 file changed, 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 8116569bca..2f12deba3b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1729,19 +1729,6 @@  (define-public hdf5-1.8
                (("libhdf5hl_fortran_la_LDFLAGS =")
                 (string-append "libhdf5hl_fortran_la_LDFLAGS = -Wl,-rpath="
                                (assoc-ref outputs "fortran") "/lib")))))
-         (add-after 'configure 'patch-settings
-           (lambda _
-             ;; libhdf5.settings contains the full path of the
-             ;; compilers used, and its contents are included in
-             ;; libhdf5.so.  We truncate the hashes to avoid
-             ;; unnecessary store references to those compilers:
-             (substitute* "src/libhdf5.settings"
-              (("(/gnu/store/)([a-zA-Z0-9]*)" all prefix hash)
-               (string-append prefix (string-take hash 10) "..."))
-              ;; Don't record the build-time kernel version to make the
-              ;; settings file reproducible.
-              (("Uname information:.*")
-               "Uname information: Linux\n"))))
          (add-after 'install 'patch-references
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((bin (string-append (assoc-ref outputs "out") "/bin"))