diff mbox series

[bug#72057] Add python-sacn

Message ID 20240711092149.12396-3-ikbenrickhuyzer@gmail.com
State New
Headers show
Series [bug#72057] Add python-sacn | expand

Commit Message

Rick Huijzer July 11, 2024, 9:20 a.m. UTC
---
Feel free to remove copyright header, I dont know the custom / rules for that.
Packaging python-sacn to maybe package more of the Open Lighting Project later.
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: 0663668507377a849317b0fff3d72f609c3139c2

Comments

Andreas Enge July 11, 2024, 8:36 p.m. UTC | #1
Hello,

thanks for the patch! It builds, but has a few minor problems,
notably with white space and other formatting issues, see here:
   https://qa.guix.gnu.org/issue/72057
These can also be found by running
   ./pre-inst-env guix lint python-sacn
locally.

Could you prepare a new version and send it following the
instructions at
   https://guix.gnu.org/de/manual/devel/en/html_node/Sending-a-Patch-Series.html#Single-Patches-1
(paragraph starting with: "If you need to send a revised patch...")?

Adding a copyright line is good practice when adding a new package.

Thanks!

Andreas
jgart July 11, 2024, 8:52 p.m. UTC | #2
>    https://qa.guix.gnu.org/issue/72057

Hi all,

Thanks for the contributions!

I fixed all the issues and enabled the tests in a separate commit.

See here:

https://git.savannah.gnu.org/cgit/guix.git/commit/?id=b06e8e1f6796391335a59efccefe110369c9632b

and here:

https://git.savannah.gnu.org/cgit/guix.git/commit/?id=91a773a65e2918519d2fb03f5d2726bee08d6186

Closing as done.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e1b2679e59..bbfe7bfdbf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -153,6 +153,7 @@ 
 ;;; Copyright © 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
 ;;; Copyright © 2024 TakeV <takev@disroot.org>
 ;;; Copyright © 2024 David Elsing <david.elsing@posteo.net>
+;;; Copyright © 2024 Rick Huijzer <ikbenrickhuyzer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -24689,6 +24690,28 @@  (define-public python-rfc6555
      and integration into other projects.")
       (license license:asl2.0))))
 
+(define-public python-sacn
+  (package
+    (name "python-sacn")
+    (version "1.10.0") 
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "sacn" version))
+        (sha256
+          (base32 "02pqfwwx83lgb8nj9p0s6vyi1s7wjgbx9k0bzlyz8qapszzdsr37")))) 
+    (build-system python-build-system)
+    (native-inputs 
+      (list python-pytest))
+    (propagated-inputs
+      (list python-setuptools)) 
+    (home-page "https://github.com/Hundemeier/sacn")
+    (synopsis "A Python library for sending and receiving sACN (Streaming Architecture for Control Networks) data")
+    (description
+      "sACN is a Python library for sending and receiving sACN (Streaming Architecture for Control Networks) data, 
+       a standard protocol used for controlling lighting and other devices over a network.")
+    (license license:expat))) 
+
 (define-public python-bagit
   (package
     (name "python-bagit")