diff mbox series

[bug#71184,1/2] gnu: Add ruby-thor-0.14.6.

Message ID 20240702133559.6250-1-adam.quandour@gmail.com
State New
Headers show
Series [bug#71184,1/2] gnu: Add ruby-thor-0.14.6. | expand

Commit Message

Adam Quandour July 2, 2024, 1:35 p.m. UTC
* gnu/packages/ruby.scm (ruby-thor-0.14.6): New variable.
---
 gnu/packages/ruby.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9547481..59d5446 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3397,6 +3397,31 @@  (define-public ruby-thor
     (home-page "http://whatisthor.com/")
     (license license:expat)))
 
+(define-public ruby-thor-0.14.6
+  ;; this package is needed for packaging ruby-appraisal
+  ;; for some reason ruby-appraisal depends on this exact
+  ;; version of this package
+  (package
+    (name "ruby-thor")
+    (version "0.14.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "thor" version))
+       (sha256
+        (base32
+         "18qmgv38gfw9clhq6szyw5kcxkkk8xr7c0klp3pk3cyznzbapif7"))))
+    (build-system ruby-build-system)
+    ;; couldn't run tests
+    ;; "No Rakefile found"
+    (arguments `(#:tests? #f))
+    (native-inputs (list ruby-rspec ruby-simplecov ruby-webmock))
+    (synopsis "Ruby toolkit for building command-line interfaces")
+    (description "Thor is a toolkit for building powerful command-line
+interfaces.")
+    (home-page "http://whatisthor.com/")
+    (license license:expat)))
+
 (define-public ruby-lumberjack
   (package
     (name "ruby-lumberjack")