diff mbox series

[bug#71787,11/12] gnu: Add python-rst2pdf.

Message ID 20240626192717.12818-11-david.elsing@posteo.net
State New
Headers show
Series Update and unbundle ghostscript and mupdf | expand

Commit Message

David Elsing June 26, 2024, 7:27 p.m. UTC
* gnu/packages/python-xyz.scm (python-rst2pdf): New variable.
---
 gnu/packages/python-xyz.scm | 53 +++++++++++++++++++++++++++++++++++++
 1 file changed, 53 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d1385ffdef..1688999d56 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6877,6 +6877,59 @@  (define-public python-docutils
     ;; licensed under the PFSL, BSD 2-clause, and GPLv3+ licenses.
     (license (list license:public-domain license:psfl license:bsd-2 license:gpl3+))))
 
+(define-public python-rst2pdf
+  (package
+    (name "python-rst2pdf")
+    (version "0.102")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "rst2pdf" version))
+       (sha256
+        (base32 "09gl8h457p4ackgmisxy41y4dx8fccj6zbnbvpfkx9skx4j0cc1p"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs
+     (list python-docutils
+           python-importlib-metadata
+           python-jinja2
+           python-packaging
+           python-pygments
+           python-pyyaml
+           python-reportlab
+           python-smartypants))
+    (native-inputs
+     (list fontconfig
+           python-pymupdf
+           python-pytest
+           python-svglib))
+    (arguments
+     (list
+      ;; These tests fail
+      #:test-flags
+      '(list
+        "-k"
+        (string-join
+         '("not test-referencing-an-aliased-font"
+           "test_aafigure"
+           "test_aafigure_extra"
+           "test_docutils_math"
+           "test_issue_231"
+           "test_issue_349"
+           "test_issue_363"
+           "test_issue_73_unicode_box_drawing_characters_renders_without_errors"
+           "test_issue_785"
+           "test_math"
+           "test_math_role"
+           "test_raw_html"
+           "test_slides")
+         " and not "))))
+    (home-page "https://rst2pdf.org")
+    (synopsis "Tool to convert reStructuredText to PDF via ReportLab")
+    (description
+     "@code{rst2pdf} is a command line tool for converting @code{reStructured}
+text to PDF files via the @code{ReportLab} library.")
+    (license license:expat)))
+
 ;; awscli refuses to be built with docutils < 0.16.
 (define-public python-docutils-0.15
   (package