diff mbox series

[bug#71787,01/12] gnu: Add lcms2mt.

Message ID 20240626192717.12818-1-david.elsing@posteo.net
State New
Headers show
Series Update and unbundle ghostscript and mupdf | expand

Commit Message

David Elsing June 26, 2024, 7:26 p.m. UTC
* gnu/packages/ghostscript.scm (lcms2mt): New variable.
---
 gnu/packages/ghostscript.scm | 23 ++++++++++++++++++++++-
 1 file changed, 22 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 502b41bb99..5f0e2cf3c4 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -10,7 +10,8 @@ 
 ;;; Copyright © 2018, 2020, 2022 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2020, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
-;;;
+;;; Copyright © 2024 David Elsing <david.elsing@posteo.net>
+;;
 ;;; This file is part of GNU Guix.
 ;;;
 ;;; GNU Guix is free software; you can redistribute it and/or modify it
@@ -43,6 +44,7 @@  (define-module (gnu packages ghostscript)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix gexp)
+  #:use-module (guix git-download)
   #:use-module (guix utils)
   #:use-module (guix build-system gnu)
   #:use-module (srfi srfi-1))
@@ -73,6 +75,25 @@  (define-public lcms
     (home-page "https://www.littlecms.com/")
     (properties '((cpe-name . "little_cms_color_engine")))))
 
+;; Fork of LCMS 2 for Ghostscript and MuPDF
+(define-public lcms2mt
+  (package
+    (inherit lcms)
+    (name "lcms2mt")
+    (version "2.16")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "git://git.ghostscript.com/thirdparty-lcms2")
+             (commit (string-append "lcms" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0dxpq59r1w3r1391fngpvka51r16505zmr32zjs2azjlrz49k3x4"))))
+    (synopsis "Little CMS, a small-footprint colour management engine
+(GhostScript fork)")
+    (home-page "https://www.ghostscript.com/")))
+
 (define-public libpaper
   (package
     (name "libpaper")