diff mbox series

[bug#71589] gnu: python-dulwich: Update to 0.20.46.

Message ID 20240616095613.2530-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#71589] gnu: python-dulwich: Update to 0.20.46. | expand

Commit Message

Nicolas Graves June 16, 2024, 9:56 a.m. UTC
* gnu/packages/python-xyz.scm (python-dulwich): Update to 0.20.46.
  [build-system]: Use pyproject-build-system.
  [propagated-inputs]: Add python-setuptools,
  python-typing-extensions.
  [native-inputs]: Replace git by git-minimal. Sort list.

Change-Id: I4f4b8896755dc789e44194265db7a2601fa4e572
---
 gnu/packages/python-xyz.scm | 18 ++++++++++++------
 1 file changed, 12 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b0a5183b6b5..732065302c6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23326,7 +23326,7 @@  (define-public python-duckdb
 (define-public python-dulwich
   (package
     (name "python-dulwich")
-    (version "0.20.30")
+    (version "0.20.46")
     (source
       (origin
         (method url-fetch)
@@ -23335,8 +23335,8 @@  (define-public python-dulwich
                    (pypi-uri "dulwich" version)))
         (sha256
           (base32
-           "0hafaff30bmkj30b8pwpwsy3fz5h6c1pn98ihqcvl5zndflr1h22"))))
-    (build-system python-build-system)
+           "0wki0rxbxcxrq41dbapviwqn38azzqjiabyrjcym5caxzzzqh3jg"))))
+    (build-system pyproject-build-system)
     (arguments
      '(#:phases
        (modify-phases %standard-phases
@@ -23349,10 +23349,16 @@  (define-public python-dulwich
              (setenv "TEST_RUNNER" "unittest")
              (setenv "PYTHONHASHSEED" "random"))))))
     (propagated-inputs
-     (list python-fastimport python-urllib3))
+     (list python-fastimport
+           python-setuptools
+           python-typing-extensions
+           python-urllib3))
     (native-inputs
-     (list python-mock python-geventhttpclient python-gpg
-           git gnupg))
+     (list git-minimal
+           gnupg
+           python-geventhttpclient
+           python-gpg
+           python-mock))
     (home-page "https://www.dulwich.io/")
     (synopsis "Git implementation in Python")
     (description "Dulwich is an implementation of the Git file formats and