diff mbox series

[bug#71588,1/2] gnu: python-shtab: Move to pyproject-build-system.

Message ID 20240616083503.26363-1-ngraves@ngraves.fr
State New
Headers show
Series Update python-shtab. | expand

Commit Message

Nicolas Graves June 16, 2024, 8:34 a.m. UTC
* gnu/packages/python-xyz.scm (python-shtab):
  [build-system]: Move to pyproject-build-system.
  [arguments]: Remove uneeded field.

Change-Id: I3c6cffb85d7335956adc3aa5a17fdf249dac6740
---
 gnu/packages/python-xyz.scm | 11 +----------
 1 file changed, 1 insertion(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index aa2d976255d..1781f36c7ad 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -35453,7 +35453,7 @@  (define-public python-shtab
         (uri (pypi-uri "shtab" version))
         (sha256
           (base32 "127mymfm7r0hddk2vknqq34fj6dirj6ip990i3g4isx0lsd7pnsc"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (native-inputs
       (list bash
             python-pytest
@@ -35461,15 +35461,6 @@  (define-public python-shtab
             python-pytest-timeout
             python-setuptools-scm
             python-wheel))
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace
-             'check
-           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
-             (when tests?
-               (add-installed-pythonpath inputs outputs)
-               (invoke "pytest")))))))
     (home-page "https://github.com/iterative/shtab")
     (synopsis "Automagic shell tab completion for Python CLI applications")
     (description