[bug#71409] gnu: pantheon-calculator: Update to 8.0.0.
Commit Message
* gnu/packages/pantheon.scm (pantheon-calculator): Update to 8.0.0.
Also run guix style on the package definition.
Change-Id: I7d935b0eef3d14990fc4dbbd408febe8de977a29
---
guix build --no-grafts --check --rounds=2 was successfully run on a Zen4 CPU,
for the following --system= options:
- x86_64-linux
- i686-linux.
gnu/packages/pantheon.scm | 37 +++++++++++++++----------------------
1 file changed, 15 insertions(+), 22 deletions(-)
Comments
altadil via Guix-patches via <guix-patches@gnu.org> writes:
> * gnu/packages/pantheon.scm (pantheon-calculator): Update to 8.0.0.
> Also run guix style on the package definition.
>
> Change-Id: I7d935b0eef3d14990fc4dbbd408febe8de977a29
> ---
> guix build --no-grafts --check --rounds=2 was successfully run on a Zen4 CPU,
> for the following --system= options:
> - x86_64-linux
> - i686-linux.
> gnu/packages/pantheon.scm | 37 +++++++++++++++----------------------
> 1 file changed, 15 insertions(+), 22 deletions(-)
Thanks for the patch, I've removed the guix style changes from this
commit as mixing them in with the version change makes it quite hard to
review. I did change the arguments to use a gexp for the phases
though. If you want to use guix style for this package, feel free to
submit another patch.
Thanks,
Chris
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2023 Wamm K. D. <jaft.r@outlook.com>
-;;; Copyright © 2023 altadil <Altadil@protonmail.com>
+;;; Copyright © 2023, 2024 altadil <Altadil@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -94,7 +94,7 @@ (define-public granite-6
(define-public pantheon-calculator
(package
(name "pantheon-calculator")
- (version "2.0.2")
+ (version "8.0.0")
(source
(origin
(method git-fetch)
@@ -103,31 +103,24 @@ (define-public pantheon-calculator
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32
- "1w59sgznzybawhz411avqayws8jq0471n6hwhkplvcz7inxlzdrw"))))
+ (base32 "1as5rxd0b6z3lnh8my36szr056rxxqwkjzvaiylspx5g2kg3qjs0"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-schema-cache-generation
- (lambda _
- (setenv "DESTDIR" "/"))))))
- (inputs
- (list granite
- glib
- gtk
- libgee
- libhandy))
- (native-inputs
- (list cmake
- `(,glib "bin") ; for glib-compile-schemas
- gettext-minimal
- pkg-config
- vala))
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'disable-schema-cache-generation
+ (lambda _
+ (setenv "DESTDIR" "/"))))))
+ (inputs (list granite glib gtk libgee libhandy))
+ (native-inputs (list cmake
+ `(,glib "bin") ;for glib-compile-schemas
+ gettext-minimal
+ pkg-config
+ vala))
(home-page "https://github.com/elementary/calculator")
(synopsis "Desktop calculator")
- (description "Calculator is an application for performing simple
+ (description
+ "Calculator is an application for performing simple
arithmetic. It is the default calculator application in the Pantheon
desktop.")
(license license:gpl3)))