diff mbox series

[bug#70869,v2] gnu: Add emacs-casual-dired.

Message ID 20240606192217.491-2-w@wmeyer.eu
State New
Headers show
Series [bug#70869,v2] gnu: Add emacs-casual-dired. | expand

Commit Message

Wilko Meyer June 6, 2024, 7:22 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-casual-dired): New variable.

Change-Id: I5208b1699baa94a610d27d2d04d5f54015d9905d
---
Hi Nicolas,

Thanks for reviewing my patch and the suggestions on how to improve
the package quality!

I've added the file-name to the package definition, removed the .git
suffix from the packages URL and changed the versioning to using tags
instead of the melpa version. As guix lint doesn't complain and the
package still successfully builds locally, I hope that everything's
alright now.

Cheers!

 gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Ludovic Courtès June 13, 2024, 8:48 p.m. UTC | #1
Hi,

Wilko Meyer <w@wmeyer.eu> skribis:

> * gnu/packages/emacs-xyz.scm (emacs-casual-dired): New variable.
>
> Change-Id: I5208b1699baa94a610d27d2d04d5f54015d9905d

[...]

> +    (license license:gpl3)))

I changed this to ‘license:gpl3+’ because the code explicitly says “or
any later version”.

Thank you, and thanks Nicolas for reviewing!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bef0afc99f..a3e54d6ca8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -139,6 +139,7 @@ 
 ;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
 ;;; Copyright © 2024 dan <i@dan.games>
 ;;; Copyright © 2024 Ilya Chernyshov <ichernyshovvv@gmail.com>
+;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -32843,6 +32844,32 @@  (define-public emacs-cascading-dir-locals
 all of your projects, then override or add variables on a per-project basis.")
       (license license:gpl3+))))
 
+(define-public emacs-casual-dired
+  (package
+    (name "emacs-casual-dired")
+    (version "1.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/kickingvegas/casual-dired")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "07dn2nfjvg348qy7kfn1kywclw9g71x8j85ilwz26pp9hv64qhmc"))))
+    (build-system emacs-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'chdir
+            (lambda _ (chdir "lisp"))))))
+    (home-page "https://github.com/kickingvegas/casual-dired")
+    (synopsis "Transient-based porcelain for dired")
+    (description
+     "Casual Dired is an opinionated Transient-based porcelain for Emacs Dired.")
+    (license license:gpl3)))
+
 (define-public emacs-calibredb
   (package
     (name "emacs-calibredb")