diff mbox series

[bug#70858,python-team,v2,29/32] build-system/pyproject: Remove python-pytest-mypy inputs.

Message ID 20240601153854.30805-30-ngraves@ngraves.fr
State New
Headers show
Series Remove unwanted native-inputs. | expand

Commit Message

Nicolas Graves June 1, 2024, 3:37 p.m. UTC
* gnu/packages/astronomy.scm (python-czml3, python-poliastro)
[native-inputs]: Remove python-pytest-mypy.

* gnu/packages/check.scm (python-pytest-perf)[native-inputs]: Remove
python-pytest-mypy.

* gnu/packages/python-web.scm (python-portend)[native-inputs]: Remove
python-pytest-mypy.

* gnu/packages/python-xyz.scm (python-importlib-resources,
python-jaraco-classes, python-jaraco-collections,
python-jaraco-context, python-jaraco-functools, python-jaraco-test,
python-jaraco-text, python-path, python-pip-run, python-inflect,
python-tempora, python-loguru, python-portalocker)[native-inputs]: Remove
python-pytest-mypy.

* gnu/packages/sphinx.scm (python-sphinx, python-sphinx-5):
[propagated-inputs]: Remove python-mypy.

Change-Id: Ia36ca82e0327a886f9c5317e9ef4ffc35dc8ac9d
---
 gnu/packages/astronomy.scm  |  4 +---
 gnu/packages/check.scm      |  1 -
 gnu/packages/python-web.scm |  1 -
 gnu/packages/python-xyz.scm | 17 ++---------------
 gnu/packages/sphinx.scm     |  2 --
 5 files changed, 3 insertions(+), 22 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 1510ecab6de..a670f3b12d9 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2228,7 +2228,6 @@  (define-public python-czml3
     (native-inputs
      (list python-astropy
            python-pytest
-           python-pytest-mypy
            python-setuptools
            python-wheel))
     (home-page "https://github.com/poliastro/czml3")
@@ -2606,8 +2605,7 @@  (define-public python-poliastro
            python-flit-core
            python-pytest
            python-pytest-doctestplus
-           python-pytest-mpl
-           python-pytest-mypy))
+           python-pytest-mpl))
     (propagated-inputs
      (list python-astropy
            python-astroquery
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index e8f121e9fe9..8eac2b13563 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2664,7 +2664,6 @@  (define-public python-pytest-perf
      (list python-pytest
            python-pytest-checkdocs
            python-pytest-enabler
-           python-pytest-mypy
            python-setuptools
            python-wheel))
     (propagated-inputs
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 93f8394ee98..f956ad5b0c2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -313,7 +313,6 @@  (define-public python-portend
     (native-inputs (list python-pytest
                          python-pytest-checkdocs
                          python-pytest-enabler
-                         python-pytest-mypy
                          python-setuptools
                          python-wheel))
     (home-page "https://github.com/jaraco/portend")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 88bea23d3b3..1069f6292f8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4928,7 +4928,6 @@  (define-public python-portalocker
                 "0lawjm736vs86wlnxc3qqh37l11z0yx81xq3dmrw33m86kaq2bh3"))))
     (build-system pyproject-build-system)
     (native-inputs (list python-pytest
-                         python-pytest-mypy
                          python-pytest-timeout
                          python-redis
                          python-setuptools
@@ -11533,7 +11532,6 @@  (define-public python-importlib-resources
      (list python-pytest
            python-pytest-checkdocs
            python-pytest-enabler
-           python-pytest-mypy
            python-setuptools-57
            python-setuptools-scm))
     (propagated-inputs
@@ -11660,7 +11658,6 @@  (define-public python-jaraco-classes
     (native-inputs
      (list python-pytest
            python-pytest-checkdocs
-           python-pytest-mypy
            python-setuptools
            python-setuptools-scm
            python-wheel))
@@ -11692,7 +11689,6 @@  (define-public python-jaraco-collections
     (native-inputs (list python-pytest
                          python-pytest-checkdocs
                          python-pytest-enabler
-                         python-pytest-mypy
                          python-setuptools
                          python-wheel))
     (home-page "https://github.com/jaraco/jaraco.collections")
@@ -11750,7 +11746,6 @@  (define-public python-jaraco-context
     (native-inputs
      (list python-pytest
            python-pytest-checkdocs
-           python-pytest-mypy
            python-setuptools
            python-setuptools-scm
            python-wheel))
@@ -11782,7 +11777,6 @@  (define-public python-jaraco-functools
      (list python-jaraco-classes
            python-pytest
            python-pytest-checkdocs
-           python-pytest-mypy
            python-setuptools
            python-setuptools-scm
            python-wheel))
@@ -11840,7 +11834,6 @@  (define-public python-jaraco-test
     (native-inputs (list python-pytest
                          python-pytest-checkdocs
                          python-pytest-enabler
-                         python-pytest-mypy
                          python-setuptools
                          python-wheel))
     (home-page "https://github.com/jaraco/jaraco.test")
@@ -11871,7 +11864,6 @@  (define-public python-jaraco-text
     (native-inputs (list python-pytest
                          python-pytest-checkdocs
                          python-pytest-enabler
-                         python-pytest-mypy
                          python-setuptools
                          python-wheel))
     (home-page "https://github.com/jaraco/jaraco.text")
@@ -16507,8 +16499,7 @@  (define-public python-path
                python-pygments
                python-pytest
                python-pytest-checkdocs
-               python-pytest-enabler
-               python-pytest-mypy)))
+               python-pytest-enabler)))
     (properties (alist-delete 'hidden?
                               (package-properties
                                python-path-bootstrap)))))
@@ -16610,8 +16601,7 @@  (define-public python-pip-run
                python-pygments
                python-pytest
                python-pytest-checkdocs
-               python-pytest-enabler
-               python-pytest-mypy)))
+               python-pytest-enabler)))
     (properties (alist-delete 'hidden? (package-properties
                                         python-pip-run-bootstrap)))))
 
@@ -21045,7 +21035,6 @@  (define-public python-inflect
                          python-pytest
                          python-pytest-checkdocs
                          python-pytest-enabler
-                         python-pytest-mypy
                          ;; For the version number
                          python-setuptools-scm
                          python-setuptools
@@ -25893,7 +25882,6 @@  (define-public python-tempora
            python-pytest-checkdocs
            python-pytest-enabler
            python-pytest-freezegun
-           python-pytest-mypy
            python-setuptools-scm
            python-types-freezegun
            python-types-pytz
@@ -32835,7 +32823,6 @@  (define-public python-loguru
     (propagated-inputs (list python-colorama))
     (native-inputs (list python-colorama
                          python-freezegun
-                         python-mypy
                          python-pre-commit
                          python-pytest
                          python-pytest-mypy-plugins
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index b977367ee35..3dbcce04b32 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -94,7 +94,6 @@  (define-public python-sphinx
            python-imagesize
            python-importlib-metadata
            python-jinja2
-           python-mypy
            python-packaging
            python-pygments
            python-requests
@@ -196,7 +195,6 @@  (define-public python-sphinx-5
            python-imagesize
            python-importlib-metadata
            python-jinja2
-           python-mypy
            python-packaging
            python-pygments
            python-requests