diff mbox series

[bug#70858,python-team,v2,27/32] build-system/pyproject: Remove python-pytest-black native-input.

Message ID 20240601153854.30805-28-ngraves@ngraves.fr
State New
Headers show
Series Remove unwanted native-inputs. | expand

Commit Message

Nicolas Graves June 1, 2024, 3:36 p.m. UTC
* gnu/packages/check.scm (python-pytest-perf, python-pytest-enabler)
[native-inputs]: Remove python-pytest-black.

* gnu/packages/python-web.scm (python-portend)[native-inputs]:
Remove python-pytest-black.

* gnu/packages/python-xyz.scm (python-importlib-resources,
python-jaraco-classes, python-jaraco-collections,
python-jaraco-context, python-jaraco-functools, python-jaraco-test,
python-jaraco-text, python-legacy-api-wrap, python-path,
python-pip-run, python-inflect, python-isort, python-tempora,
python-sparse)[native-inputs]: Remove python-pytest-black.

Change-Id: Ib46f1c4a3cc33821cda3d7b2172d36158aa812c9
---
 gnu/packages/check.scm      |  2 --
 gnu/packages/python-web.scm |  1 -
 gnu/packages/python-xyz.scm | 21 ++++-----------------
 3 files changed, 4 insertions(+), 20 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 6b16ec7711b..f8ead8df4e4 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2491,7 +2491,6 @@  (define-public python-pytest-enabler
            python-jaraco-functools
            python-toml))
     (native-inputs (list python-pytest
-                         python-pytest-black
                          python-pytest-checkdocs
                          python-pytest-flake8
                          python-pytest-mypy
@@ -2664,7 +2663,6 @@  (define-public python-pytest-perf
                            "and not upstream_url"))))
     (native-inputs
      (list python-pytest
-           python-pytest-black
            python-pytest-checkdocs
            python-pytest-enabler
            python-pytest-flake8
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0b794590620..98dc11a9e48 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -311,7 +311,6 @@  (define-public python-portend
     (propagated-inputs (list python-tempora))
     ;; TODO: Add python-pytest-ruff to native-inputs once it has been packaged.
     (native-inputs (list python-pytest
-                         python-pytest-black
                          python-pytest-checkdocs
                          python-pytest-enabler
                          python-pytest-mypy
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c8766db819b..8dd5bf2e9e3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8691,7 +8691,6 @@  (define-public python-sparse
      (list python-dask
            python-importlib-metadata
            python-pytest
-           python-pytest-black
            python-setuptools))
     (home-page "https://github.com/pydata/sparse/")
     (synopsis "Library for multi-dimensional sparse arrays")
@@ -11532,7 +11531,6 @@  (define-public python-importlib-resources
                      (string-append (getcwd) "/_custom_build")))))))
     (native-inputs
      (list python-pytest
-           python-pytest-black
            python-pytest-checkdocs
            python-pytest-enabler
            python-pytest-flake8
@@ -11662,7 +11660,6 @@  (define-public python-jaraco-classes
       #:test-flags '(list "-k" "not project")))
     (native-inputs
      (list python-pytest
-           python-pytest-black
            python-pytest-checkdocs
            python-pytest-flake8
            python-pytest-mypy
@@ -11695,7 +11692,6 @@  (define-public python-jaraco-collections
     ;; TODO: Add python-pytest-ruff to native-inputs once it has been
     ;; packaged.
     (native-inputs (list python-pytest
-                         python-pytest-black
                          python-pytest-checkdocs
                          python-pytest-enabler
                          python-pytest-mypy
@@ -11755,7 +11751,6 @@  (define-public python-jaraco-context
            #:test-flags '(list "-k" "not project")))
     (native-inputs
      (list python-pytest
-           python-pytest-black
            python-pytest-checkdocs
            python-pytest-flake8
            python-pytest-mypy
@@ -11789,7 +11784,6 @@  (define-public python-jaraco-functools
     (native-inputs
      (list python-jaraco-classes
            python-pytest
-           python-pytest-black
            python-pytest-checkdocs
            python-pytest-flake8
            python-pytest-mypy
@@ -11849,7 +11843,6 @@  (define-public python-jaraco-test
      (list #:test-flags '(list "-k" "http")))
     (propagated-inputs (list python-jaraco-context python-jaraco-functools))
     (native-inputs (list python-pytest
-                         python-pytest-black
                          python-pytest-checkdocs
                          python-pytest-enabler
                          python-pytest-flake8
@@ -11882,7 +11875,6 @@  (define-public python-jaraco-text
     ;; TODO: Add python-pytest-ruff to native-inputs once it has been
     ;; packaged.
     (native-inputs (list python-pytest
-                         python-pytest-black
                          python-pytest-checkdocs
                          python-pytest-enabler
                          python-pytest-mypy
@@ -16260,8 +16252,7 @@  (define-public python-legacy-api-wrap
          "06qhp0g543dy98vpa41hwdalvdbsjfc3ldk474yr9sd75mhl8jh3"))))
     (build-system python-build-system)
     (propagated-inputs
-     (list python-get-version python-pytest python-pytest-black
-           python-setuptools))
+     (list python-get-version python-pytest python-setuptools))
     (home-page "https://github.com/flying-sheep/legacy-api-wrap")
     (synopsis "Legacy API wrapper")
     (description "This module defines a decorator to wrap legacy APIs.  The
@@ -16521,7 +16512,6 @@  (define-public python-path
                python-packaging
                python-pygments
                python-pytest
-               python-pytest-black
                python-pytest-checkdocs
                python-pytest-enabler
                python-pytest-flake8
@@ -16626,7 +16616,6 @@  (define-public python-pip-run
        (append python-nbformat
                python-pygments
                python-pytest
-               python-pytest-black
                python-pytest-checkdocs
                python-pytest-enabler
                python-pytest-flake8
@@ -21062,7 +21051,6 @@  (define-public python-inflect
     (propagated-inputs (list python-pydantic))
     (native-inputs (list python-pygments
                          python-pytest
-                         python-pytest-black
                          python-pytest-checkdocs
                          python-pytest-enabler
                          python-pytest-flake8
@@ -24092,7 +24080,8 @@  (define-public python-isort
     (arguments
      (list
       #:test-flags '(list "tests/unit/" "-k" "not test_gitignore"
-                          "--ignore=tests/unit/test_deprecated_finders.py")
+                          "--ignore=tests/unit/test_deprecated_finders.py"
+                          "--ignore=tests/unit/profiles/test_black.py")
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'install 'install-example-plugins
@@ -24110,8 +24099,7 @@  (define-public python-isort
                 (apply invoke "pip" "--no-cache-dir" "--no-input"
                        "install"  "--user" "--no-deps" example-whls)))))))
     (native-inputs
-     (list python-black
-           python-colorama
+     (list python-colorama
            python-hypothesmith
            python-libcst-minimal
            python-natsort
@@ -25911,7 +25899,6 @@  (define-public python-tempora
     (native-inputs
      (list python-freezegun
            python-pytest
-           python-pytest-black
            python-pytest-checkdocs
            python-pytest-enabler
            python-pytest-flake8