diff mbox series

[bug#70858,python-team,v2,26/32] build-system/pyproject: Remove python-pytest-isort native-input.

Message ID 20240601153854.30805-27-ngraves@ngraves.fr
State New
Headers show
Series Remove unwanted native-inputs. | expand

Commit Message

Nicolas Graves June 1, 2024, 3:36 p.m. UTC
* gnu/packages/dav.scm (radicale):
  [native-inputs]: Remove python-pytest-isort.

* gnu/packages/python-web.scm (python-tinycss):
  [arguments]<#:test-flags>: Ignore isort tests.
  [native-inputs]: Remove python-pytest-isort.

Change-Id: I706e8c310adbeda49b91c6815d299172ce05df22
---
 gnu/packages/dav.scm        | 1 -
 gnu/packages/python-web.scm | 3 +--
 2 files changed, 1 insertion(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index 0612a72c831..99284220846 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -59,7 +59,6 @@  (define-public radicale
     (native-inputs
      (list python-pytest
            python-pytest-flake8
-           python-pytest-isort
            python-pytest-runner
            python-waitress))
     (propagated-inputs
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 707bf903bd1..0b794590620 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5861,10 +5861,9 @@  (define-public python-tinycss
     (build-system pyproject-build-system)
     (arguments
      (list #:test-flags
-           '(list "-k" "not test_speedups")))
+           '(list "-k" "not ISORT and not test_speedups")))
     (native-inputs
      (list python-pytest-flake8
-           python-pytest-isort
            python-pytest-runner
            python-setuptools
            python-wheel))