diff mbox series

[bug#70858,python-team,v2,23/32] gnu: python-tinycss2: Remove python-pytest-cov native-input.

Message ID 20240601153854.30805-24-ngraves@ngraves.fr
State New
Headers show
Series Remove unwanted native-inputs. | expand

Commit Message

Nicolas Graves June 1, 2024, 3:36 p.m. UTC
* gnu/packages/python-web.scm (python-tinycss2):
  [arguments]<#:phases>: Add phase remove-unwanted-dependency to
  ignore coverage options.
  [native-inputs]: Remove python-pytest-cov.

Change-Id: I853fe3371be84be1655db0ee8d1dca8d23c50ef9
---
 gnu/packages/python-web.scm | 11 +++++++++--
 1 file changed, 9 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c1f803cb131..707bf903bd1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5897,11 +5897,18 @@  (define-public python-tinycss2
        (sha256
         (base32 "0zyc48vbmczpqj7f3f0d7zb3bz29fyj50dg0m6bbwbr5i88kq3sq"))))
     (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'remove-unwanted-dependencies
+            (lambda _
+              (substitute* "pyproject.toml"
+                (("^addopts.*") "")))))))
     (propagated-inputs
      (list python-webencodings))
     (native-inputs
-     (list python-flit python-pytest python-pytest-cov
-           python-pytest-flake8 python-pytest-isort))
+     (list python-flit python-pytest python-pytest-flake8 python-pytest-isort))
     (home-page "https://tinycss2.readthedocs.io/")
     (synopsis "Low-level CSS parser for Python")
     (description "@code{tinycss2} can parse strings, return Python objects