diff mbox series

[bug#70858,python-team,v2,19/32] gnu: python-immutables: Remove python-mypy native-input.

Message ID 20240601153854.30805-20-ngraves@ngraves.fr
State New
Headers show
Series Remove unwanted native-inputs. | expand

Commit Message

Nicolas Graves June 1, 2024, 3:36 p.m. UTC
* gnu/packages/python-xyz.scm (python-immutables):
  [origin]: Use git-fetch to use upstream test-data directory.
  [build-system]: Move to pyrpoject-build-system.
  [native-inputs]: Remove python-mypy.
  [arguments]<#:phases>: Add phase to remove python-mypy native-input.

Change-Id: Ie67f634ffecbc3711f354e915b2fab54a1639925
---
 gnu/packages/python-xyz.scm | 17 +++++++++++++----
 1 file changed, 13 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 963747bb06a..180158e3b64 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15824,13 +15824,22 @@  (define-public python-immutables
     (version "0.18")
     (source
      (origin
-       (method url-fetch)
-       (uri (pypi-uri "immutables" version))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/MagicStack/immutables")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "1x4cinh0xbl6p6p2yfm2s07mxxy3lf0zzai9gqpydk4482bwfdjk"))))
+        (base32 "1xjbkgls0dqrvpg4yzkdzz6aayizxcv5chjc5gyynk196wyshw4m"))))
     (build-system pyproject-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (add-after 'unpack 'remove-mypy-dependency
+                          (lambda _
+                            (delete-file "tests/test_mypy.py")
+                            (delete-file "tests/conftest.py"))))))
     (native-inputs
-     (list python-mypy python-pytest python-setuptools python-wheel))
+     (list python-pytest python-setuptools python-wheel))
     (home-page "https://github.com/MagicStack/immutables")
     (synopsis "High-performance immutable mapping type for Python")
     (description