diff mbox series

[bug#70858,python-team,v2,13/32] gnu: python-versioneer: Remove python-pycodestyle native-input.

Message ID 20240601153854.30805-14-ngraves@ngraves.fr
State New
Headers show
Series Remove unwanted native-inputs. | expand

Commit Message

Nicolas Graves June 1, 2024, 3:36 p.m. UTC
* gnu/packages/python-xyz.scm (python-versioneer):
  [arguments]<#:phases>: Remove pycodestyle invocation in check phase.
  [native-inputs]: Remove python-pycodestyle.

Change-Id: Ida3fd1e16cb8656be2af666203a82cb9f6d65f75
---
 gnu/packages/python-xyz.scm | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0b618024383..3f5cac16d45 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -32668,11 +32668,9 @@  (define-public python-versioneer
                 (invoke "python" "setup.py" "make_long_version_py_git")
                 (invoke "pyflakes" "setup.py" "versioneer.py" "git_version.py")
                 (invoke "python" "test/run_pyflakes_src.py")
-                (invoke "pyflakes" "test")
-                (invoke "pycodestyle" "--max-line-length=88"
-                        "git_version.py" "versioneer.py")))))))
+                (invoke "pyflakes" "test")))))))
     (native-inputs
-     (list git-minimal python-pycodestyle python-pyflakes
+     (list git-minimal python-pyflakes
            python-pypa-build python-setuptools python-wheel))
     (propagated-inputs
      (list python-tomli))