diff mbox series

[bug#69980,python-team,v3,14/14] gnu: jupytext: Fix pre-commit native-input removal.

Message ID 20240601145902.26806-15-ngraves@ngraves.fr
State New
Headers show
Series Update pre-commit and remove dependents | expand

Commit Message

Nicolas Graves June 1, 2024, 2:58 p.m. UTC
* gnu/packages/python-xyz.scm (jupytext):
  [arguments]<#:test-flags>: Add a flag to ignore pre_commit tests.

Change-Id: Ifa2097da721c4927ec304c51371eea96bc0cdf41
---
 gnu/packages/python-xyz.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ae94d13e803..d81de891c4f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -465,7 +465,8 @@  (define-public python-jupytext
                     (list "test_create_header_with_set_formats"
                           "test_pre_commit_hook"
                           "test_sync_with_pre_commit_hook")
-                    " and not ")))
+                    " and not "))
+             "--ignore-glob=tests/test_pre_commit_*.py")
       #:phases
       #~(modify-phases %standard-phases
           (add-before 'check 'pre-check