diff mbox series

[bug#69980,python-team,v3,10/14] gnu: python-identify: Update to 2.5.36.

Message ID 20240601145902.26806-11-ngraves@ngraves.fr
State New
Headers show
Series Update pre-commit and remove dependents | expand

Commit Message

Nicolas Graves June 1, 2024, 2:57 p.m. UTC
From: Vinicius Monego <monego@posteo.net>

* gnu/packages/python-xyz.scm (python-identify): Update to 2.5.36.
[build-system]: Use pyproject-build-system.
[arguments]: Use G-Expressions. Do not override the check phase.
[native-inputs]: Add python-ukkonen.

Change-Id: I970507dc358029b4e2cc0a295d19db4b28202544
---
 gnu/packages/python-xyz.scm | 21 +++++++++------------
 1 file changed, 9 insertions(+), 12 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cfff41569e1..53762b111f3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27595,7 +27595,7 @@  (define-public python-ukkonen
 (define-public python-identify
   (package
     (name "python-identify")
-    (version "1.4.25")
+    (version "2.5.36")
     (source
      (origin
        ;; There are no tests in the PyPI tarball.
@@ -27605,19 +27605,16 @@  (define-public python-identify
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1fqgci6skckcq0x5pnxh6k2qjzn1ndsrgha1j6wwv1ld4g9bd3hz"))))
-    (build-system python-build-system)
+        (base32 "1il0d1zh31jx36m0lvhpiykx95i95dcfrgrfbz2x6la884zsmvq8"))))
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         ;; system-error "utime" "~A" ("No such file or directory")
-         (delete 'ensure-no-mtimes-pre-1980)
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "pytest" "-vv")))))))
+     (list
+      #:phases #~(modify-phases %standard-phases
+                   ;; system-error "utime" "~A" ("No such file or directory")
+                   (delete 'ensure-no-mtimes-pre-1980))))
     (native-inputs
-     (list python-coverage python-pytest python-setuptools python-wheel))
+     (list python-coverage python-pytest python-setuptools
+           python-ukkonen python-wheel))
     (propagated-inputs
      (list python-editdistance))
     (home-page "https://github.com/chriskuehl/identify")