diff mbox series

[bug#71121,v2,3/3] gnu: librewolf: Update to 126.0-1.

Message ID 20240530223951.13474-3-ian@retrospec.tv
State New
Headers show
Series [bug#71121,v2,1/3] gnu: all-mozilla-locales: Add Santali locale; make public. | expand

Commit Message

Ian Eure May 30, 2024, 10:39 p.m. UTC
* gnu/packages/librewolf.scm (librewolf): Update to 126.0-1.  Fixes
CVE-2024-4367, CVE-2024-4764, CVE-2024-4765, CVE-2024-4766, CVE-2024-4767,
CVE-2024-4768, CVE-2024-4769, CVE-2024-4770, CVE-2024-4771, CVE-2024-4772,
CVE-2024-4773, CVE-2024-4774, CVE-2024-4775, CVE-2024-4776, CVE-2024-4777,
CVE-2024-4778.

Change-Id: Iec010e516651588da389f747074cbd10f8c14377
---
 gnu/packages/librewolf.scm | 15 ++++++++++-----
 1 file changed, 10 insertions(+), 5 deletions(-)

Comments

Maxim Cournoyer June 1, 2024, 11:33 a.m. UTC | #1
Hi Ian,

Ian Eure <ian@retrospec.tv> writes:

> * gnu/packages/librewolf.scm (librewolf): Update to 126.0-1.  Fixes
> CVE-2024-4367, CVE-2024-4764, CVE-2024-4765, CVE-2024-4766, CVE-2024-4767,
> CVE-2024-4768, CVE-2024-4769, CVE-2024-4770, CVE-2024-4771, CVE-2024-4772,
> CVE-2024-4773, CVE-2024-4774, CVE-2024-4775, CVE-2024-4776, CVE-2024-4777,
> CVE-2024-4778.
>
> Change-Id: Iec010e516651588da389f747074cbd10f8c14377

I've moved some of the commit message explanations to match the
following template:

--8<---------------cut here---------------start------------->8---
$summary

$rationale/explanations

$gnu-changelog
--8<---------------cut here---------------end--------------->8---

along with some trivial adjustments, tested it could build reproducibly*
and pushed.  Thank you for your work on this fine browser!

* as mentioned on IRC I did notice the build failing
non-deterministically when using a monstrous number of cores such as
180; that seems to be a shortcoming of cargo and/or the firefox build
system.
diff mbox series

Patch

diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index bb8bc8a283..80b942ec12 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -115,9 +115,9 @@  (define (librewolf-source-origin version hash)
 (define computed-origin-method (@@ (guix packages) computed-origin-method))
 
 (define librewolf-source
-  (let* ((ff-src (firefox-source-origin "125.0.2" "16gpd6n52lshvkkha41z7xicggj64dw0qhr5gd07bcxsc4rmdl39"))
-         (version "125.0.2-1")
-         (lw-src (librewolf-source-origin version "17i36s2ny1pv3cz44w0gz48fy4vjfw6vp9jk21j62f5d3dl726x8")))
+  (let* ((ff-src (firefox-source-origin "126.0" "09l5hsyrkimmkd7wbhnamy5mwmwwxjfa742hpkjjkhlyk6hq43li"))
+         (version "126.0-1")
+         (lw-src (librewolf-source-origin version "1q8fjki6rgzrir84y7j2anra2w213bm0g74nw205gja9qsxlassc")))
 
     (origin
       (method computed-origin-method)
@@ -161,6 +161,11 @@  (define librewolf-source
                  (("^ff_source_tarball:=.*")
                   (string-append "ff_source_tarball:=" #+ff-src)))
 
+               ;; Remove encoding_rs patch, it doesn't build with Rust 1.75.
+               (substitute* '("assets/patches.txt")
+                 (("patches/encoding_rs.patch\\\n$")
+                  ""))
+
                ;; Stage locales
                (begin
                  (format #t "Staging locales...~%")
@@ -205,12 +210,12 @@  (define rust-librewolf rust) ; 1.75 is the default in Guix, 1.65 is the minimum.
 ;; Update this id with every update to its release date.
 ;; It's used for cache validation and therefore can lead to strange bugs.
 ;; ex: date '+%Y%m%d%H%M%S'
-(define %librewolf-build-id "20240427150329")
+(define %librewolf-build-id "20240530072108")
 
 (define-public librewolf
   (package
     (name "librewolf")
-    (version "125.0.2-1")
+    (version "126.0-1")
     (source librewolf-source)
     (build-system gnu-build-system)
     (arguments