diff mbox series

[bug#71239] gnu: Add emacs-dape.

Message ID 20240528095800.20728-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#71239] gnu: Add emacs-dape. | expand

Commit Message

Nicolas Graves May 28, 2024, 9:57 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-dape): New variable.

Change-Id: Ia07745dd47b2e1e5b85654a5b4b2400dd4c4cc13
---
 gnu/packages/emacs-xyz.scm | 52 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 52 insertions(+)

Comments

Jelle Licht June 9, 2024, 8:52 p.m. UTC | #1
Hi Nicolas,

I've got some nitpicks, and one question as the package does not seem to
run for me, which could very well be an issue on my end.

Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-dape): New variable.
>
> Change-Id: Ia07745dd47b2e1e5b85654a5b4b2400dd4c4cc13
> ---
>  gnu/packages/emacs-xyz.scm | 52 ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 52 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 1c890a5b008..9f93d582f3f 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -31088,6 +31088,58 @@ (define-public emacs-lsp-docker
>  in Docker environment.")
>        (license license:gpl3+))))
>  
> +(define-public emacs-dape
> +  (let ((commit "51fad7df7473778fbc4bac703317de7f7713b307")
> +        (revision "0"))
> +    (package
> +      (name "emacs-dape")
> +      (version (git-version "0.12.0" revision commit))
Is there a particular reason not to stick to the 'proper' releases? 
If so, could you add a comment explaining why?

> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/svaante/dape")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32 "1jics02b9fxjs0lykiv7z924z18id550mqhf6piqzv0sgan91pg2"))))
> +      (build-system emacs-build-system)
> +      (arguments
> +       ;; FIXME python tests pass, JS tests require additional dependencies
> +       ;; See https://lists.sr.ht/~abcdw/rde-devel/patches/51878
> +       (list #:tests? #f
Can't we patch out or disable the JS tests, instead of not running any tests?

> +             #:test-command #~'("emacs" "--batch" "-l" "dape.el"
> +                                "-l" "dape-tests.el"
> +                                "-f" "ert-run-tests-batch-and-exit")
> +             #:phases
> +             #~(modify-phases %standard-phases
> +                 (add-after 'unpack 'support-unwrapped-python
> +                   (lambda _
> +                     (substitute* "dape.el"
> +                       (("command \"python\"")
> +                        "command \"python3\""))))

I don't think we do this kind of patching for other packages, but I
could be mistaken of course. If this was needed to get the python tests
to succeed, maybe it could also work with python-minimal-wrapper instead
of patching.

> +                 (add-before 'check 'pre-check
> +                   (lambda* (#:key tests? inputs #:allow-other-keys)
> +                     (if tests?
> +                         (setenv
> +                          "PATH"
> +                          (string-append
> +                           (getenv "PATH")
> +                           ":" (dirname (search-input-file inputs "/bin/python3"))
> +                           ":" (dirname (search-input-file inputs "/bin/node"))))

Ditto wrt my earlier remark about the JS tests.

> +                         (format #t "test suite not run~%")))))))
> +      (native-inputs (list node-lts python-minimal python-debugpy))
> +      (propagated-inputs (list emacs-jsonrpc))

Did running this package once installed actually work on your local
setup?  If so, I'd love to know how you are running this package, as I'm
running into the issue as the one I reported at
https://issues.guix.gnu.org/71065

> +      (home-page "https://github.com/svaante/dape")
> +      (synopsis "Debug Adapter Protocol for Emacs")
> +      (description
> +       "Dape is a debug adapter client for Emacs.  The debug adapter protocol,
> +much like its more well-known counterpart, the language server protocol,
> +aims to establish a common API for programming tools.  However, instead of
> +functionalities such as code completions, it provides a standardized
> +interface for debuggers.")
> +      (license license:gpl3+))))
> +
>  (define-public emacs-dap-mode
>    (package
>      (name "emacs-dap-mode")
> -- 
> 2.41.0


Thanks for the package,
 - Jelle
Nicolas Graves June 10, 2024, 7:50 a.m. UTC | #2
On 2024-06-09 22:52, Jelle Licht wrote:

> Hi Nicolas,
>
> I've got some nitpicks, and one question as the package does not seem to
> run for me, which could very well be an issue on my end.
>
>> +      (name "emacs-dape")
>> +      (version (git-version "0.12.0" revision commit))
> Is there a particular reason not to stick to the 'proper' releases? 
> If so, could you add a comment explaining why?

There are no upstream tags, this is simply the commit of the tag,
IIRC. So it's the proper release. Maybe I should simply put the version
here and use git-version in the origin field instead ?

>> +      (arguments
>> +       ;; FIXME python tests pass, JS tests require additional dependencies
>> +       ;; See https://lists.sr.ht/~abcdw/rde-devel/patches/51878
>> +       (list #:tests? #f
> Can't we patch out or disable the JS tests, instead of not running any
> tests?

Doable, although using I'm not sure there's a light approach for this
rather than patching half the file, which I think is not worth it. Will
investigate. 

>> +             #:test-command #~'("emacs" "--batch" "-l" "dape.el"
>> +                                "-l" "dape-tests.el"
>> +                                "-f" "ert-run-tests-batch-and-exit")
>> +             #:phases
>> +             #~(modify-phases %standard-phases
>> +                 (add-after 'unpack 'support-unwrapped-python
>> +                   (lambda _
>> +                     (substitute* "dape.el"
>> +                       (("command \"python\"")
>> +                        "command \"python3\""))))
>
> I don't think we do this kind of patching for other packages, but I
> could be mistaken of course. If this was needed to get the python tests
> to succeed, maybe it could also work with python-minimal-wrapper instead
> of patching.

Since python is not propagated, this would mean that we expect the user
to have python-wrapper instead of python, I'm not sure we want to
enforce that because it might cause users to have to debug this. We
can of course propagate python-wrapper instead, but then we increase the
closure size.

>> +                         (format #t "test suite not run~%")))))))
>> +      (native-inputs (list node-lts python-minimal python-debugpy))
>> +      (propagated-inputs (list emacs-jsonrpc))
>
> Did running this package once installed actually work on your local
> setup?  If so, I'd love to know how you are running this package, as I'm
> running into the issue as the one I reported at
> https://issues.guix.gnu.org/71065

No, actually I couldn't, but I didn't settled for a stable
configuration, I wanted to send that to RDE, but haven't done it
yet.

> Thanks for the package,
>  - Jelle
Nicolas Graves June 10, 2024, 7:56 a.m. UTC | #3
On 2024-06-09 22:52, Jelle Licht wrote:

> Hi Nicolas,
>
> I've got some nitpicks, and one question as the package does not seem to
> run for me, which could very well be an issue on my end.

Ow I probably have forgotten to block the patch, but it depends on
emacs-jsonrpc@0.25, which is not the current version in Guix.

I've sent a patch in 70998. Although I understand now that updating
native emacs packages is not that simple - I've seen a mail thread about
this.
>
> Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:
>
>> * gnu/packages/emacs-xyz.scm (emacs-dape): New variable.
>>
>> Change-Id: Ia07745dd47b2e1e5b85654a5b4b2400dd4c4cc13
>> ---
>>  gnu/packages/emacs-xyz.scm | 52 ++++++++++++++++++++++++++++++++++++++
>>  1 file changed, 52 insertions(+)
>>
>> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
>> index 1c890a5b008..9f93d582f3f 100644
>> --- a/gnu/packages/emacs-xyz.scm
>> +++ b/gnu/packages/emacs-xyz.scm
>> @@ -31088,6 +31088,58 @@ (define-public emacs-lsp-docker
>>  in Docker environment.")
>>        (license license:gpl3+))))
>>  
>> +(define-public emacs-dape
>> +  (let ((commit "51fad7df7473778fbc4bac703317de7f7713b307")
>> +        (revision "0"))
>> +    (package
>> +      (name "emacs-dape")
>> +      (version (git-version "0.12.0" revision commit))
> Is there a particular reason not to stick to the 'proper' releases? 
> If so, could you add a comment explaining why?
>
>> +      (source
>> +       (origin
>> +         (method git-fetch)
>> +         (uri (git-reference
>> +               (url "https://github.com/svaante/dape")
>> +               (commit commit)))
>> +         (file-name (git-file-name name version))
>> +         (sha256
>> +          (base32 "1jics02b9fxjs0lykiv7z924z18id550mqhf6piqzv0sgan91pg2"))))
>> +      (build-system emacs-build-system)
>> +      (arguments
>> +       ;; FIXME python tests pass, JS tests require additional dependencies
>> +       ;; See https://lists.sr.ht/~abcdw/rde-devel/patches/51878
>> +       (list #:tests? #f
> Can't we patch out or disable the JS tests, instead of not running any tests?
>
>> +             #:test-command #~'("emacs" "--batch" "-l" "dape.el"
>> +                                "-l" "dape-tests.el"
>> +                                "-f" "ert-run-tests-batch-and-exit")
>> +             #:phases
>> +             #~(modify-phases %standard-phases
>> +                 (add-after 'unpack 'support-unwrapped-python
>> +                   (lambda _
>> +                     (substitute* "dape.el"
>> +                       (("command \"python\"")
>> +                        "command \"python3\""))))
>
> I don't think we do this kind of patching for other packages, but I
> could be mistaken of course. If this was needed to get the python tests
> to succeed, maybe it could also work with python-minimal-wrapper instead
> of patching.
>
>> +                 (add-before 'check 'pre-check
>> +                   (lambda* (#:key tests? inputs #:allow-other-keys)
>> +                     (if tests?
>> +                         (setenv
>> +                          "PATH"
>> +                          (string-append
>> +                           (getenv "PATH")
>> +                           ":" (dirname (search-input-file inputs "/bin/python3"))
>> +                           ":" (dirname (search-input-file inputs "/bin/node"))))
>
> Ditto wrt my earlier remark about the JS tests.
>
>> +                         (format #t "test suite not run~%")))))))
>> +      (native-inputs (list node-lts python-minimal python-debugpy))
>> +      (propagated-inputs (list emacs-jsonrpc))
>
> Did running this package once installed actually work on your local
> setup?  If so, I'd love to know how you are running this package, as I'm
> running into the issue as the one I reported at
> https://issues.guix.gnu.org/71065
>
>> +      (home-page "https://github.com/svaante/dape")
>> +      (synopsis "Debug Adapter Protocol for Emacs")
>> +      (description
>> +       "Dape is a debug adapter client for Emacs.  The debug adapter protocol,
>> +much like its more well-known counterpart, the language server protocol,
>> +aims to establish a common API for programming tools.  However, instead of
>> +functionalities such as code completions, it provides a standardized
>> +interface for debuggers.")
>> +      (license license:gpl3+))))
>> +
>>  (define-public emacs-dap-mode
>>    (package
>>      (name "emacs-dap-mode")
>> -- 
>> 2.41.0
>
>
> Thanks for the package,
>  - Jelle
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1c890a5b008..9f93d582f3f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31088,6 +31088,58 @@  (define-public emacs-lsp-docker
 in Docker environment.")
       (license license:gpl3+))))
 
+(define-public emacs-dape
+  (let ((commit "51fad7df7473778fbc4bac703317de7f7713b307")
+        (revision "0"))
+    (package
+      (name "emacs-dape")
+      (version (git-version "0.12.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/svaante/dape")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1jics02b9fxjs0lykiv7z924z18id550mqhf6piqzv0sgan91pg2"))))
+      (build-system emacs-build-system)
+      (arguments
+       ;; FIXME python tests pass, JS tests require additional dependencies
+       ;; See https://lists.sr.ht/~abcdw/rde-devel/patches/51878
+       (list #:tests? #f
+             #:test-command #~'("emacs" "--batch" "-l" "dape.el"
+                                "-l" "dape-tests.el"
+                                "-f" "ert-run-tests-batch-and-exit")
+             #:phases
+             #~(modify-phases %standard-phases
+                 (add-after 'unpack 'support-unwrapped-python
+                   (lambda _
+                     (substitute* "dape.el"
+                       (("command \"python\"")
+                        "command \"python3\""))))
+                 (add-before 'check 'pre-check
+                   (lambda* (#:key tests? inputs #:allow-other-keys)
+                     (if tests?
+                         (setenv
+                          "PATH"
+                          (string-append
+                           (getenv "PATH")
+                           ":" (dirname (search-input-file inputs "/bin/python3"))
+                           ":" (dirname (search-input-file inputs "/bin/node"))))
+                         (format #t "test suite not run~%")))))))
+      (native-inputs (list node-lts python-minimal python-debugpy))
+      (propagated-inputs (list emacs-jsonrpc))
+      (home-page "https://github.com/svaante/dape")
+      (synopsis "Debug Adapter Protocol for Emacs")
+      (description
+       "Dape is a debug adapter client for Emacs.  The debug adapter protocol,
+much like its more well-known counterpart, the language server protocol,
+aims to establish a common API for programming tools.  However, instead of
+functionalities such as code completions, it provides a standardized
+interface for debuggers.")
+      (license license:gpl3+))))
+
 (define-public emacs-dap-mode
   (package
     (name "emacs-dap-mode")