diff mbox series

[bug#71237] gnu: Add font-teko.

Message ID 20240527235538.15923-1-sirgazil@zoho.com
State New
Headers show
Series [bug#71237] gnu: Add font-teko. | expand

Commit Message

ashish.is--- via Guix-patches" via May 27, 2024, 11:55 p.m. UTC
From: Luis Felipe <sirgazil@zoho.com>

* gnu/packages/fonts.scm (font-teko): New variable.

Change-Id: I09ca2e04bfe1e4decf2a8fd9c028cb58bcda1033
---
 gnu/packages/fonts.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)


base-commit: 00384aedbc6a371aaf90ca344a446952fdd5a6b3

Comments

Nicolas Graves June 14, 2024, 3:35 a.m. UTC | #1
user guix
usertag 71237 + reviewed-looks-good
thanks

Guix QA review form submission:


Items marked as checked: Lint warnings, Package builds, Commit messages, New package licenses, New package tests, New package synopsis and descriptions
Andreas Enge June 14, 2024, 2:05 p.m. UTC | #2
Pushed, thanks for the patch and the review!

Andreas
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index a5c8cfadce..384028328e 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3840,3 +3840,40 @@  (define-public font-oswald
 used freely across the internet by web browsers on desktop computers,
 laptops and mobile devices.")
       (license license:silofl1.1))))
+
+(define-public font-teko
+  (let ((version "0")
+        (commit "2bf909d46b0061a5e3e16e8acc4fef670e36a8f2")
+        (revision "0"))
+    (package
+      (name "font-teko")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/googlefonts/teko")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "18gwb3k4a3a2406pxpxh9zcziggajl8wwki4730xsh1m066f6gk9"))))
+      (build-system font-build-system)
+      (home-page "https://github.com/googlefonts/teko")
+      (synopsis "Devanagari and Latin scripts typeface")
+      (description "Teko is a typeface that currently supports the
+Devanagari and Latin scripts.  This font family has been created for
+use in headlines and other display-sized text on screen.  Five font
+styles make up the initial release.
+
+The Teko typeface features letterforms with low stroke contrast,
+square proportions and a structure that appears visually simple.
+
+The Regular, Medium and Semibold fonts are recommended for use in long
+headlines, while Bold is intended primarily for setting just one or
+two words.  The Light is a variant that may be put to good use in
+large headlines on websites.  At display sizes, Teko works equally
+well on screen or in print.  Each font contains 1090 glyphs, offering
+full support for the conjuncts and ligatures required by languages
+written with the Devanagari script.")
+      (license license:silofl1.1))))