diff mbox series

[bug#71067,1/2] gnu: godot-lts: Update to 3.5.3.

Message ID 20240519161612.700-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#71067,1/2] gnu: godot-lts: Update to 3.5.3. | expand

Commit Message

Nicolas Graves May 19, 2024, 4:16 p.m. UTC
* gnu/packages/game-development.scm (godot-lts): Update to 3.5.3.
  [arguments]<#:scons>: Update to scons-python. Remove argument.
  <#:phases>: Rename phase 'wrap to 'wrap-ld-path, remove mesa-related
  comment that seems to be fixed.
  [inputs]: Replace freetype by freetype-with-brotli.

Change-Id: Ia83bc33bd0b944342ba413b46f0963d3f2197bf5
---
 gnu/packages/game-development.scm | 22 ++++++++--------------
 1 file changed, 8 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 5b7852c4eb9..9591fae7f9e 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1927,7 +1927,7 @@  (define-public openmw
 (define-public godot-lts
   (package
     (name "godot")
-    (version "3.4.2")
+    (version "3.5.3")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1936,7 +1936,7 @@  (define-public godot-lts
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1bm9yl995chvx6jwkdia12yjrgwcpzb1r9bmj606q8z264aw2ma5"))
+                "0zibc6am9axbbm8l57jf2d324a2m44pf6ncp2i4h1b219jjq89l6"))
               (modules '((guix build utils)
                          (ice-9 ftw)
                          (srfi srfi-1)))
@@ -1948,7 +1948,6 @@  (define-public godot-lts
                   (with-directory-excursion "thirdparty"
                     (let* ((preserved-files
                             '("README.md"
-                              "assimp"
                               "certs"
                               "cvtt"
                               "embree"
@@ -1966,6 +1965,7 @@  (define-public godot-lts
                               "oidn"
                               "pvrtccompressor"
                               "recastnavigation"
+                              "rvo2"
                               "squish"
                               "stb_rect_pack"
                               "tinyexr"
@@ -1977,8 +1977,7 @@  (define-public godot-lts
                                                  (cons* "." ".." preserved-files)))))))))
     (build-system scons-build-system)
     (arguments
-     `(#:scons ,scons-python2
-       #:scons-flags (list "platform=x11" "target=release_debug"
+     `(#:scons-flags (list "platform=x11" "target=release_debug"
                            ;; Avoid using many of the bundled libs.
                            ;; Note: These options can be found in the SConstruct file.
                            "builtin_bullet=no"
@@ -2032,18 +2031,13 @@  (define-public godot-lts
                ;; Tell the editor where to find zenity for OS.alert().
                (wrap-program (string-append out "/bin/godot")
                  `("PATH" ":" prefix (,(string-append zenity "/bin")))))))
-         (add-after 'install 'wrap
+         (add-after 'install 'wrap-ld-path
            (lambda* (#:key inputs outputs #:allow-other-keys)
-             ;; FIXME: Mesa tries to dlopen libudev.so.0 and fails.  Pending a
-             ;; fix of the mesa package we wrap the pcb executable such that
-             ;; Mesa can find libudev.so.0 through LD_LIBRARY_PATH.
-             ;; also append ld path for pulseaudio and alsa-lib
              (let* ((out (assoc-ref outputs "out"))
-                    (udev_path (string-append (assoc-ref inputs "eudev") "/lib"))
                     (pulseaudio_path (string-append (assoc-ref inputs "pulseaudio") "/lib"))
                     (alas_lib_path (string-append (assoc-ref inputs "alsa-lib") "/lib")))
                (wrap-program (string-append out "/bin/godot")
-                 `("LD_LIBRARY_PATH" ":" prefix (,udev_path ,pulseaudio_path ,alas_lib_path))))))
+                 `("LD_LIBRARY_PATH" ":" prefix (,pulseaudio_path ,alas_lib_path))))))
          (add-after 'install 'install-godot-desktop
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
@@ -2064,7 +2058,7 @@  (define-public godot-lts
     (inputs
      (list alsa-lib
            bullet
-           freetype
+           freetype-with-brotli
            glew
            glu
            libtheora
@@ -2081,7 +2075,7 @@  (define-public godot-lts
            opusfile
            pcre2
            pulseaudio
-           eudev                        ; FIXME: required by mesa
+           eudev
            wslay
            zenity
            `(,zstd "lib")))