diff mbox series

[bug#70317,v5,02/13] gnu: packages: Add go-github-com-msteinert-pam

Message ID 20240504083033.29426-3-jesse@eisses.email
State New
Headers show
Series Add Soju | expand

Commit Message

Jesse Eisses May 4, 2024, 8:30 a.m. UTC
Change-Id: Id2b8424033b37846a6a0fbc3ff222e8bd31c9998
---
 gnu/packages/golang-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 4e40e148f2..bbf70fbdbc 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -34,6 +34,7 @@ 
 ;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
 ;;; Copyright © 2024 Herman Rimm <herman@rimm.ee>
+;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -60,6 +61,7 @@  (define-module (gnu packages golang-xyz)
   #:use-module (guix utils)
   #:use-module (gnu packages)
   #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages gcc)
   #:use-module (gnu packages golang)
   #:use-module (gnu packages golang-build)
   #:use-module (gnu packages golang-check)
@@ -2454,6 +2456,33 @@  (define-public go-github-com-multiformats-go-multibase
 multibase} (self identifying base encodings) in Go.")
     (license license:expat)))
 
+(define-public go-github-com-msteinert-pam
+  (package
+    (name "go-github-com-msteinert-pam")
+    (version "1.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/msteinert/pam")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1qnr0zxyxny85andq3cbj90clmz2609j8z9mp0zvdyxiwryfhyhj"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:go gccgo-12
+      ;; tests don't work, they require special root set up
+      #:tests? #f
+      #:import-path "github.com/msteinert/pam"))
+    (inputs (list linux-pam))
+    (propagated-inputs (list go-golang-org-x-term))
+    (home-page "https://github.com/msteinert/pam")
+    (synopsis "Go PAM")
+    (description "Package pam provides a wrapper for the PAM application API.")
+    (license license:bsd-2)))
+
 (define-public go-github-com-multiformats-go-multicodec
   (package
     (name "go-github-com-multiformats-go-multicodec")