diff mbox series

[bug#70680,1/1] * gnu/packages/golang.scm (go-1.22): Disable flakey tests.

Message ID 20240430175415.61463-1-cox.katherine.e@gmail.com
State New
Headers show
Series [bug#70680,1/1] * gnu/packages/golang.scm (go-1.22): Disable flakey tests. | expand

Commit Message

Katherine Cox-Buday April 30, 2024, 5:54 p.m. UTC
---
 gnu/packages/golang.scm | 10 ++++++++--
 1 file changed, 8 insertions(+), 2 deletions(-)


base-commit: 8dab3df9529387ec1459d5483ac9664969c52e78

Comments

Sharlatan Hellseher May 14, 2024, 10:50 a.m. UTC | #1
Pushed as 6fab2d5b318fb0a8a0887f6ce0ac3e342a8c23ef to go-team.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4ce6f5ea6b..99d83dd104 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12,7 +12,7 @@ 
 ;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
 ;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2018, 2019, 2020, 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
+;;; Copyright © 2018, 2019, 2020, 2023, 2024 Katherine Cox-Buday <cox.katherine.e@gmail.com>
 ;;; Copyright © 2019 Giovanni Biscuolo <g@xelera.eu>
 ;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2019, 2020, 2021 Arun Isaac <arunisaac@systemreboot.net>
@@ -971,7 +971,13 @@  (define-public go-1.22
                 ;; to perl input in sourcecode generators and test scripts
                 (substitute* (find-files "src" "\\.pl$")
                   (("^#!.*")
-                   "#!/usr/bin/env perl\n"))))))))
+                   "#!/usr/bin/env perl\n"))))
+            (add-after 'unpack 'remove-flakey-thread-sanitizer-tests
+              (lambda _
+                ;; These tests have been identified as flakey:
+                ;; https://github.com/golang/go/issues/66427
+                (substitute* "src/cmd/cgo/internal/testsanitizers/tsan_test.go"
+                  ((".*tsan1[34].*") ""))))))))
     (native-inputs
      ;; Go 1.22 and later requires Go 1.20 (min. 1.20.6, which we don't have)
      ;; as the bootstrap toolchain.