diff mbox series

[bug#70317,v4,10/13] gnu: go-github-com-prometheus-client-golang: Update to 1.17.0

Message ID 20240429201649.2851-11-jesse@eisses.email
State New
Headers show
Series Add Soju | expand

Commit Message

Jesse Eisses April 29, 2024, 8:08 p.m. UTC
---
 gnu/packages/golang-xyz.scm | 8 +++++++-
 gnu/packages/golang.scm     | 4 ++--
 2 files changed, 9 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index cdfc4c2f6b..67ff1018c0 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2544,7 +2544,13 @@  (define-public go-github-com-nbrownus-go-metrics-prometheus
        (sha256
         (base32 "1kl9l08aas544627zmhkgp843qx94sxs4inxm20nw1hx7gp79dz0"))))
     (build-system go-build-system)
-    (arguments '(#:import-path "github.com/nbrownus/go-metrics-prometheus"))
+    (arguments
+     '(#:import-path "github.com/nbrownus/go-metrics-prometheus"
+       ;; TODO: The tests fail because they expect an older version of
+       ;; go-github-com-prometheus-client-golang (v1.1.0) that has a slightly
+       ;; different output format. This would be resolved by the following PR:
+       ;; https://github.com/nbrownus/go-metrics-prometheus/pull/2
+       #:tests? #f))
     (native-inputs
      (list go-github-com-stretchr-testify))
     (propagated-inputs
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c4888d95fc..d4d242fcfb 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7950,7 +7950,7 @@  (define-public go-github-com-prometheus-procfs
 (define-public go-github-com-prometheus-client-golang
   (package
     (name "go-github-com-prometheus-client-golang")
-    (version "1.2.1")
+    (version "1.17.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -7959,7 +7959,7 @@  (define-public go-github-com-prometheus-client-golang
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0zs49psk23n9z8wrl02d5vib5wclpym8kaxcy6n5pk696i419065"))))
+                "1v8vdvi9wlpf18nxi62diysfnh9gc3c3cqq6hvx378snsvvl6n82"))))
     (build-system go-build-system)
     (arguments
      '(#:tests? #f