diff mbox series

[bug#70317,v2,08/13] gnu: packages: Add go-git-sr-ht-sircmpwn-go-bare

Message ID 20240425221648.5322-10-jesse@eisses.email
State New
Headers show
Series Add soju | expand

Commit Message

Jesse Eisses April 25, 2024, 10:08 p.m. UTC
---
 gnu/packages/golang-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 7a07f823d2..cdfc4c2f6b 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3355,6 +3355,32 @@  (define-public go-git-sr-ht-emersion-go-sqlite3-fts5
 search functionality to database applications..")
     (license license:expat)))
 
+(define-public go-git-sr-ht-sircmpwn-go-bare
+  (package
+    (name "go-git-sr-ht-sircmpwn-go-bare")
+    (version "0.0.0-20210406120253-ab86bc2846d9")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~sircmpwn/go-bare")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0zh36qppk8lscd8mysy0anm2vw5c74c10f4qvhd541wxm06di928"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "git.sr.ht/~sircmpwn/go-bare"))
+    (propagated-inputs
+     (list
+      go-github-com-stretchr-testify
+      go-git-sr-ht-sircmpwn-getopt))
+    (home-page "https://git.sr.ht/~sircmpwn/go-bare")
+    (synopsis "Implementation of the BARE message format")
+    (description "An implementation of the BARE message format for Go.")
+    (license license:asl2.0)))
+
 (define-public go-go-uber-org-automaxprocs
   (package
     (name "go-go-uber-org-automaxprocs")