diff mbox series

[bug#70428,2/2] gnu: diffoscope: Update to 265.

Message ID 20240419193117.425782-2-vagrant@reproducible-builds.org
State New
Headers show
Series [bug#70428,1/2] gnu: reprotest: Update to 0.7.27. | expand

Commit Message

Vagrant Cascadian April 19, 2024, 7:31 p.m. UTC
From: Vagrant Cascadian <vagrant@reproducible-builds.org>

* gnu/packages/diffoscope.scm (diffoscope): Update to 265.
[native-inputs]: Fix architecture specific conditional for "enjarify"
---
 gnu/packages/diffoscope.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

Vagrant Cascadian April 19, 2024, 7:44 p.m. UTC | #1
On 2024-04-19, vagrant@reproducible-builds.org wrote:
> From: Vagrant Cascadian <vagrant@reproducible-builds.org>
>
> * gnu/packages/diffoscope.scm (diffoscope): Update to 265.
> [native-inputs]: Fix architecture specific conditional for "enjarify"

The tag for 265 landed. Yay!

I think I'm done pushing trivial fixes now!

live well,
  vagrant


> ---
>  gnu/packages/diffoscope.scm | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
> index d97ce5dda2..fd2146456d 100644
> --- a/gnu/packages/diffoscope.scm
> +++ b/gnu/packages/diffoscope.scm
> @@ -75,7 +75,7 @@ (define-module (gnu packages diffoscope)
>  (define-public diffoscope
>    (package
>      (name "diffoscope")
> -    (version "263")
> +    (version "265")
>      (source
>       (origin
>         (method git-fetch)
> @@ -84,7 +84,7 @@ (define-public diffoscope
>               (commit version)))
>         (file-name (git-file-name name version))
>         (sha256
> -        (base32 "1bq45gyn214hf9brnn5xlj9xvcg6p0yr8cc2p153f93pgzsyqlg4"))))
> +        (base32 "0fdaxihmzz1jf9ay8pwr1z60b2rnihawp4js4nw9l7wv0gij9vpg"))))
>      (build-system python-build-system)
>      (arguments
>       (list
> @@ -233,9 +233,9 @@ (define (bin command)
>          ;; openjdk and dependent packages are only
>          ;; available on x86_64 currently.
>          ((or "x86_64-linux")
> -         (list enjarify)
>           ;; No unversioned openjdk available.
> -         (list `(,openjdk12 "jdk")))
> +         (list `(,openjdk12 "jdk")
> +               enjarify))
>          (_ '()))))
>      (home-page "https://diffoscope.org/")
>      (synopsis "Compare files, archives, and directories in depth")
> -- 
> 2.39.2
diff mbox series

Patch

diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index d97ce5dda2..fd2146456d 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -75,7 +75,7 @@  (define-module (gnu packages diffoscope)
 (define-public diffoscope
   (package
     (name "diffoscope")
-    (version "263")
+    (version "265")
     (source
      (origin
        (method git-fetch)
@@ -84,7 +84,7 @@  (define-public diffoscope
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1bq45gyn214hf9brnn5xlj9xvcg6p0yr8cc2p153f93pgzsyqlg4"))))
+        (base32 "0fdaxihmzz1jf9ay8pwr1z60b2rnihawp4js4nw9l7wv0gij9vpg"))))
     (build-system python-build-system)
     (arguments
      (list
@@ -233,9 +233,9 @@  (define (bin command)
         ;; openjdk and dependent packages are only
         ;; available on x86_64 currently.
         ((or "x86_64-linux")
-         (list enjarify)
          ;; No unversioned openjdk available.
-         (list `(,openjdk12 "jdk")))
+         (list `(,openjdk12 "jdk")
+               enjarify))
         (_ '()))))
     (home-page "https://diffoscope.org/")
     (synopsis "Compare files, archives, and directories in depth")