diff mbox series

[bug#70428,1/3] gnu: diffoscope: Update to 264.

Message ID 20240419182553.352485-1-vagrant@reproducible-builds.org
State New
Headers show
Series [bug#70428,1/3] gnu: diffoscope: Update to 264. | expand

Commit Message

Vagrant Cascadian April 19, 2024, 6:25 p.m. UTC
From: Vagrant Cascadian <vagrant@reproducible-builds.org>

* gnu/packages/diffoscope.scm (diffoscope): Update to 264.
[native-inputs]: Fix architecture specific conditional for "enjarify"
---
 gnu/packages/diffoscope.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)


base-commit: e4b758e70561af9a673ac46d8d754ae4e7240341

Comments

Christopher Baines April 23, 2024, 1:59 p.m. UTC | #1
vagrant@reproducible-builds.org writes:

> From: Vagrant Cascadian <vagrant@reproducible-builds.org>
>
> * gnu/packages/diffoscope.scm (diffoscope): Update to 264.
> [native-inputs]: Fix architecture specific conditional for "enjarify"
> ---
>  gnu/packages/diffoscope.scm | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)

Thanks, I've removed the commit/tag bit when updating to 265 as the tag
seems to now exist, and I've pushed these patches to master as
10d0e2d3110e4be2bc6cfecb9a3abb83d8e1ddd6.

Chris
Vagrant Cascadian April 23, 2024, 7:22 p.m. UTC | #2
On 2024-04-23, Christopher Baines wrote:
> vagrant@reproducible-builds.org writes:
>
>> From: Vagrant Cascadian <vagrant@reproducible-builds.org>
>>
>> * gnu/packages/diffoscope.scm (diffoscope): Update to 264.
>> [native-inputs]: Fix architecture specific conditional for "enjarify"
>> ---
>>  gnu/packages/diffoscope.scm | 8 ++++----
>>  1 file changed, 4 insertions(+), 4 deletions(-)
>
> Thanks, I've removed the commit/tag bit when updating to 265 as the tag
> seems to now exist, and I've pushed these patches to master as
> 10d0e2d3110e4be2bc6cfecb9a3abb83d8e1ddd6.

Curiously, looks like my last patchset which dropped 264 and switched
back to the tag for 265 was never imported into guix-patches.git, though
it seems to be patchwork:

  https://patches.guix-patches.cbaines.net/project/guix-patches/list/?series=22495


Though having the complete history with both revisions versions is fine
by me too. Thanks! :)


live well,
  vagrant
diff mbox series

Patch

diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 8106a6d258..fbcf3a36f2 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -75,7 +75,7 @@  (define-module (gnu packages diffoscope)
 (define-public diffoscope
   (package
     (name "diffoscope")
-    (version "263")
+    (version "264")
     (source
      (origin
        (method git-fetch)
@@ -84,7 +84,7 @@  (define-public diffoscope
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1bq45gyn214hf9brnn5xlj9xvcg6p0yr8cc2p153f93pgzsyqlg4"))))
+        (base32 "1m2jrg0y283m07gml7nd6fy4x827i93bj23varjn3add4kixxr57"))))
     (build-system python-build-system)
     (arguments
      (list
@@ -233,9 +233,9 @@  (define (bin command)
         ;; openjdk and dependent packages are only
         ;; available on x86_64 currently.
         ((or "x86_64-linux")
-         (list enjarify)
          ;; No unversioned openjdk available.
-         (list `(,openjdk12 "jdk")))
+         (list `(,openjdk12 "jdk")
+               enjarify))
         (_ '()))))
     (home-page "https://diffoscope.org/")
     (synopsis "Compare files, archives, and directories in depth")