diff mbox series

[bug#70431,1/2] gnu: contourpy: Correct dependencies.

Message ID 20240417054040.15563-1-ngraves@ngraves.fr
State New
Headers show
Series Correct some Python dependencies. | expand

Commit Message

Nicolas Graves April 17, 2024, 5:40 a.m. UTC
* gnu/packages/python-xyz.scm (contourpy): Correct dependencies.
  [propagated-inputs]: Move all except python-numpy from here...
  [native-inputs]: ...to here.

Change-Id: I99048270570689ed9ceab6e0ff6db9561193425e
---
 gnu/packages/python-xyz.scm | 24 +++++++++++++-----------
 1 file changed, 13 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 44c709a880..643c427392 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1144,17 +1144,19 @@  (define-public python-contourpy
              "--ignore=tests/test_filled.py"
              "--ignore=tests/test_lines.py"
              "--ignore=tests/test_renderer.py")))
-    (propagated-inputs (list python-mypy
-                             python-numpy
-                             python-pillow
-                             python-pytest
-                             python-pytest-cov
-                             python-pytest-xdist
-                             python-selenium
-                             python-sphinx
-                             python-sphinx-copybutton
-                             python-wurlitzer))
-    (native-inputs (list meson-python pybind11-2.10 pkg-config))
+    (propagated-inputs (list python-numpy))
+    (native-inputs (list meson-python
+                         pybind11-2.10
+                         pkg-config
+                         python-mypy
+                         python-pillow
+                         python-pytest
+                         python-pytest-cov
+                         python-pytest-xdist
+                         python-selenium
+                         python-sphinx
+                         python-sphinx-copybutton
+                         python-wurlitzer))
     (home-page "https://contourpy.readthedocs.io/")
     (synopsis
      "Python library for calculating contours of 2D quadrilateral grids")