diff mbox series

[bug#70309,v2] gnu: simavr: Remove modules from arguments.

Message ID 20240412082549.1334944-1-guix-devel-0brg6a@rdmp.org
State New
Headers show
Series [bug#70309,v2] gnu: simavr: Remove modules from arguments. | expand

Commit Message

Dale Mellor April 12, 2024, 8:25 a.m. UTC
From: Jean-Pierre De Jesus DIAZ <jean@foundation.xyz>

* gnu/packages/avr-xyz.scm (simavr) <arguments>: Remove the #:modules
keyword argument as it contains the default modules only.

Review:
  * Trivial change, totally benign
  * lint/build-check/install all clean

Reviewed-by: Dale Mellor <guix-devel-0brg6a@rdmp.org>
Change-Id: Idf350cad53db879e90a53849c23ac4e63b53cfd1
---
 gnu/packages/avr-xyz.scm | 2 --
 1 file changed, 2 deletions(-)

Comments

Christopher Baines April 15, 2024, 9:33 a.m. UTC | #1
Dale Mellor <guix-devel-0brg6a@rdmp.org> writes:

> From: Jean-Pierre De Jesus DIAZ <jean@foundation.xyz>
>
> * gnu/packages/avr-xyz.scm (simavr) <arguments>: Remove the #:modules
> keyword argument as it contains the default modules only.
>
> Review:
>   * Trivial change, totally benign
>   * lint/build-check/install all clean
>
> Reviewed-by: Dale Mellor <guix-devel-0brg6a@rdmp.org>
> Change-Id: Idf350cad53db879e90a53849c23ac4e63b53cfd1
> ---
>  gnu/packages/avr-xyz.scm | 2 --
>  1 file changed, 2 deletions(-)

Thanks both, I've pushed this to master as
188168ee08f1913b1d11cdef153020c96d3f18fe.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/avr-xyz.scm b/gnu/packages/avr-xyz.scm
index e6092df082..86ac941770 100644
--- a/gnu/packages/avr-xyz.scm
+++ b/gnu/packages/avr-xyz.scm
@@ -62,8 +62,6 @@  (define-public simavr
     (arguments
      (list
       #:tests? #f
-      #:modules '((guix build gnu-build-system)
-                  (guix build utils))
       #:phases #~(modify-phases %standard-phases
                    (delete 'configure)
                    (replace 'check