diff mbox series

[bug#70152,v2] gnu: Borg: Update to 1.2.8.

Message ID 20240412080101.1332966-1-guix-devel-0brg6a@rdmp.org
State New
Headers show
Series [bug#70152,v2] gnu: Borg: Update to 1.2.8. | expand

Commit Message

Dale Mellor April 12, 2024, 8:01 a.m. UTC
From: Leo Famulari <leo@famulari.name>

* gnu/packages/backup.scm (borg): Update to 1.2.8.
[arguments]: Remove a variety of workarounds that have been obviated by changes
upstream and in the Python package build tools.

Review:
  * guix lint throws false positive due to deprecation in package:inputs field
  * guix build --check is clean
  * guix install is clean
  * it works for me

Reviewed-by: Dale Mellor <guix-devel-0brg6a@rdmp.org>

Change-Id: I031bb4e6ac2f562a3e387a5e815b31416367766f
---
 gnu/packages/backup.scm | 17 ++++-------------
 1 file changed, 4 insertions(+), 13 deletions(-)

Comments

Christopher Baines April 15, 2024, 9:32 a.m. UTC | #1
Dale Mellor <guix-devel-0brg6a@rdmp.org> writes:

> From: Leo Famulari <leo@famulari.name>
>
> * gnu/packages/backup.scm (borg): Update to 1.2.8.
> [arguments]: Remove a variety of workarounds that have been obviated by changes
> upstream and in the Python package build tools.
>
> Review:
>   * guix lint throws false positive due to deprecation in package:inputs field
>   * guix build --check is clean
>   * guix install is clean
>   * it works for me
>
> Reviewed-by: Dale Mellor <guix-devel-0brg6a@rdmp.org>
>
> Change-Id: I031bb4e6ac2f562a3e387a5e815b31416367766f
> ---
>  gnu/packages/backup.scm | 17 ++++-------------
>  1 file changed, 4 insertions(+), 13 deletions(-)

Thanks both, I've pushed this to master as
2c059863483b698c4f6f50a2ce4daaef5f1de83f.

Chris
Leo Famulari April 17, 2024, 6:06 p.m. UTC | #2
On Mon, Apr 15, 2024 at 10:32:53AM +0100, Christopher Baines wrote:
> Thanks both, I've pushed this to master as
> 2c059863483b698c4f6f50a2ce4daaef5f1de83f.

Thanks to Dale and Chris!
diff mbox series

Patch

diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 699f4cbc8f..44365d3bcb 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -675,13 +675,13 @@  (define-public libchop
 (define-public borg
   (package
     (name "borg")
-    (version "1.2.7")
+    (version "1.2.8")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "borgbackup" version))
        (sha256
-        (base32 "06j1v4bw9jkjh6m29ns5sigmp0cslcf0cyy8rrqij11w72ijhgzn"))
+        (base32 "1aplj54x6hcyg3mnzscnwi07npy7nrws2246ss25ax6bsaq257fk"))
        (modules '((guix build utils)))
        (snippet
         #~(begin
@@ -723,18 +723,10 @@  (define-public borg
                 (setenv "BORG_OPENSSL_PREFIX" openssl)
                 (setenv "BORG_LIBLZ4_PREFIX" lz4)
                 (setenv "BORG_LIBXXHASH_PREFIX" xxhash)
-                (setenv "BORG_LIBZSTD_PREFIX" zstd)
-                (setenv "PYTHON_EGG_CACHE" "/tmp")
-                ;; The test 'test_return_codes[python]' fails when
-                ;; HOME=/homeless-shelter.
-                (setenv "HOME" "/tmp"))))
-          ;; The tests need to be run after Borg is installed.
-          (delete 'check)
-          (add-after 'install 'check
+                (setenv "BORG_LIBZSTD_PREFIX" zstd))))
+          (replace 'check
             (lambda* (#:key inputs outputs tests? #:allow-other-keys)
               (when tests?
-                ;; Make the installed package available for the test suite.
-                (add-installed-pythonpath inputs outputs)
                 ;; The tests should be run in an empty directory.
                 (mkdir-p "tests")
                 (with-directory-excursion "tests"
@@ -749,7 +741,6 @@  (define-public borg
                            "and not test_access_acl "
                            "and not test_default_acl "
                            "and not test_get_item_uid_gid "
-                           "and not test_non_ascii_acl "
                            "and not test_create_content_from_command "
                            "and not test_create_content_from_command_with_failed_command "
                            "and not test_create_stdin "