diff mbox series

[bug#69896,v3] gnu: Add emacs-noman.

Message ID 20240411191605.1308781-1-guix-devel-0brg6a@rdmp.org
State New
Headers show
Series [bug#69896,v3] gnu: Add emacs-noman. | expand

Commit Message

Dale Mellor April 11, 2024, 7:16 p.m. UTC
From: Suhail Singh <suhailsingh247@gmail.com>

* gnu/packages/emacs-xyz.scm (emacs-noman): New variable.

Review:
  * Synopsis and description are brief but fine
  * License is correct
  * Patch applies clean, guix lint and guix build --check report no problems
    are introduced
  * Tested by installing, adding '(require 'noman)' to emacs.el, running emacs
    and issuing 'M-x noman<ret>git<ret>' and then navigating the help pages
    (this is actually pretty cool!)
  * *Very* cursory look over the upstream source code shows nothing malicious

Reviewed-by: Dale Mellor <guix-devel-0brg6a@rdmp.org>
Change-Id: I4ef3de3723025832c6b6eae47de67c3377366602
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Suhail Singh April 11, 2024, 11:56 p.m. UTC | #1
Dale Mellor <guix-devel-0brg6a@rdmp.org> writes:

> Review:
>   * Synopsis and description are brief but fine
>   * License is correct
>   * Patch applies clean, guix lint and guix build --check report no problems
>     are introduced
>   * Tested by installing, adding '(require 'noman)' to emacs.el, running emacs
>     and issuing 'M-x noman<ret>git<ret>' and then navigating the help pages
>     (this is actually pretty cool!)
>   * *Very* cursory look over the upstream source code shows nothing malicious

Thank you for the review!

I noticed that the v3 patch you sent introduced some changes to v2.
Specifically, the commit and file-name fields were being hard-coded
instead of referencing the version and name.  I'm assuming this change
was unintentional and I've reverted it in v4 of the patch.

If, however, the change was intentional, could you please elaborate on
the reasons?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f35aa3e514..49e385f466 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5445,6 +5445,28 @@  (define-public emacs-mmt
 Lisp developers who want to write macros with convenience.")
     (license license:gpl3+)))
 
+(define-public emacs-noman
+  (package
+    (name "emacs-noman")
+    (home-page "https://github.com/andykuszyk/noman.el")
+    (version "0.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit "v0.3")))
+       (file-name "emacs-noman-0.3")
+       (sha256
+        (base32 "04hvh816a0dvakgn22lxzw8qjmvc8grb5nhg1b5w99j5606ljqcl"))))
+    (build-system emacs-build-system)
+    (synopsis "Emacs package for browsing CLI command docs without man pages")
+    (description
+     "@code{noman} is an Emacs package that parses command line help from
+flags like @code{--help}, and presents it in an easy-to-navigate Emacs
+buffer.")
+    (license license:gpl3+)))
+
 (define-public emacs-tablist
   (package
     (name "emacs-tablist")