diff mbox series

[bug#70149] gnu: Add kwalletmanager.

Message ID 20240402164626.19466-1-sughosha@disroot.org
State New
Headers show
Series [bug#70149] gnu: Add kwalletmanager. | expand

Commit Message

Sughosha April 2, 2024, 4:46 p.m. UTC
* gnu/packages/kde-utils.scm (kwalletmanager): New variable.
---
 gnu/packages/kde-utils.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

Comments

Z572 April 3, 2024, 1:57 p.m. UTC | #1
Sughosha via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/kde-utils.scm (kwalletmanager): New variable.
> ---
>  gnu/packages/kde-utils.scm | 38 ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 38 insertions(+)
>
> diff --git a/gnu/packages/kde-utils.scm b/gnu/packages/kde-utils.scm
> index 6735bf2aea..6f8fd995d1 100644
> --- a/gnu/packages/kde-utils.scm
> +++ b/gnu/packages/kde-utils.scm
> @@ -984,6 +984,44 @@ (define-public krusader
>  great on your desktop.")
>      (license license:gpl2+)))
>  
> +(define-public kwalletmanager
> +  (package
> +    (name "kwalletmanager")
> +    (version "23.04.3")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "mirror://kde/stable/release-service/" version
> +                           "/src/kwalletmanager-" version ".tar.xz"))
> +       (sha25670149
> +        (base32 "1g3yw32kv7yij2ymk52fpp0srncr2ijfckfvz5hc0nsn7xhyqdby"))))
> +    (build-system qt-build-system)
> +    (native-inputs
> +     (list extra-cmake-modules kdoctools))
> +    (inputs
> +     (list karchive
> +           kauth
> +           kcmutils
> +           kconfig
> +           kconfigwidgets
> +           kcoreaddons
> +           kcrash
> +           kdbusaddons
> +           ki18n
> +           kio
> +           kjobwidgets
> +           knotifications
> +           kservice
> +           ktextwidgets
> +           kwallet
> +           kwindowsystem
> +           kxmlgui))
> +    (home-page "https://apps.kde.org/kwalletmanager5/")
> +    (synopsis "Tool to manage passwords on KWallet")
> +    (description
> +     "This package provides a tool to manage passwords on @code{kwallet}.")
> +    (license license:gpl2+)))
> +
>  (define-public kxstitch
>    (package
>      (name "kxstitch")

LGTM
Sughosha April 7, 2024, 9:24 a.m. UTC | #2
I think that kwalletmanager fits better in kde-systemtools.
diff mbox series

Patch

diff --git a/gnu/packages/kde-utils.scm b/gnu/packages/kde-utils.scm
index 6735bf2aea..6f8fd995d1 100644
--- a/gnu/packages/kde-utils.scm
+++ b/gnu/packages/kde-utils.scm
@@ -984,6 +984,44 @@  (define-public krusader
 great on your desktop.")
     (license license:gpl2+)))
 
+(define-public kwalletmanager
+  (package
+    (name "kwalletmanager")
+    (version "23.04.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/release-service/" version
+                           "/src/kwalletmanager-" version ".tar.xz"))
+       (sha256
+        (base32 "1g3yw32kv7yij2ymk52fpp0srncr2ijfckfvz5hc0nsn7xhyqdby"))))
+    (build-system qt-build-system)
+    (native-inputs
+     (list extra-cmake-modules kdoctools))
+    (inputs
+     (list karchive
+           kauth
+           kcmutils
+           kconfig
+           kconfigwidgets
+           kcoreaddons
+           kcrash
+           kdbusaddons
+           ki18n
+           kio
+           kjobwidgets
+           knotifications
+           kservice
+           ktextwidgets
+           kwallet
+           kwindowsystem
+           kxmlgui))
+    (home-page "https://apps.kde.org/kwalletmanager5/")
+    (synopsis "Tool to manage passwords on KWallet")
+    (description
+     "This package provides a tool to manage passwords on @code{kwallet}.")
+    (license license:gpl2+)))
+
 (define-public kxstitch
   (package
     (name "kxstitch")