diff mbox series

[bug#70098] gnu: gtk: Fix tests on aarch64.

Message ID 20240331031704.1604-1-hello@lnikki.la
State New
Headers show
Series [bug#70098] gnu: gtk: Fix tests on aarch64. | expand

Commit Message

Leo Nikkilä March 31, 2024, 3:14 a.m. UTC
GTK tests are currently failing on aarch64 with:

    36/1521 gtk:gsk+gsk-compare+gsk-gl+gsk-compare-gl+wayland_gles_failing / gl big-checkerboard-scaled-down2                                              FAIL            0.37s   exit status 1
    37/1521 gtk:gsk+gsk-compare+gsk-gl+gsk-compare-gl+wayland_gles_failing+gsk-compare-flipped-gl / gl big-checkerboard-scaled-down2 flipped               FAIL            0.32s   exit status 1
    38/1521 gtk:gsk+gsk-compare+gsk-gl+gsk-compare-gl+wayland_gles_failing+gsk-compare-repeated-gl / gl big-checkerboard-scaled-down2 repeated             FAIL            0.25s   exit status 1
    39/1521 gtk:gsk+gsk-compare+gsk-gl+gsk-compare-gl+wayland_gles_failing+gsk-compare-rotated-gl / gl big-checkerboard-scaled-down2 rotated               FAIL            0.32s   exit status 1
    40/1521 gtk:gsk+gsk-compare+gsk-gl+gsk-compare-gl+wayland_gles_failing+gsk-compare-masked-gl / gl big-checkerboard-scaled-down2 masked                 FAIL            0.26s   exit status 1

Seems other distributions like Debian have disabled these tests due to
similar issues, although I'm unsure why they're also failing with the
X11 test setup.

* gnu/packages/gtk.scm (gtk)[arguments]<#:test-options>: Skip failing
tests like Debian.
---
 gnu/packages/gtk.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Comments

Efraim Flashner April 2, 2024, 6:17 p.m. UTC | #1
I had previously added a phase to manually skip those tests but I like
your way with the configure flag much better.

Thanks! Patch pushed (and my own reverted).
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 9252315fd2..da56834df6 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1157,7 +1157,12 @@  (define-public gtk
                             "--no-suite=failing"
                             "--no-suite=flaky"
                             "--no-suite=headless" ; requires mutter…
-                            "--no-suite=gsk-compare-broadway")
+                            "--no-suite=gsk-compare-broadway"
+                            ;; These seem to fail on aarch64, and Debian has
+                            ;; also disabled these, see:
+                            ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1050075
+                            "--no-suite=wayland_failing"
+                            "--no-suite=wayland_gles_failing")
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'generate-gdk-pixbuf-loaders-cache-file