diff mbox series

[bug#70042] gnu: Replace deprecated po4a-* calls with po4a

Message ID 20240328010246.1662097-1-aaron.covrig.us@ieee.org
State New
Headers show
Series [bug#70042] gnu: Replace deprecated po4a-* calls with po4a | expand

Commit Message

Aaron Covrig March 28, 2024, 1:02 a.m. UTC
* configure.ac: updates deprecated po4a-translate and po4a-updatepo
* guix/self.scm: updates deprecated po4a-translate

Change-Id: I938afb217c732715cf877aeb7891081bf87b2e0a
---
 configure.ac  | 3 +--
 guix/self.scm | 2 +-
 2 files changed, 2 insertions(+), 3 deletions(-)


base-commit: 28bc0e870b4d48b8e3e773382bb0e999df2e3611

Comments

Aaron Covrig March 28, 2024, 1:12 a.m. UTC | #1
This patch addresses warnings about po4a-translate being deprecated
during the build process. Details on the deprecation can be found in
the po4a FAQ section found here: https://po4a.org/man/man7/po4a.7.php

v/r,

Aaron Covrig
pelzflorian (Florian Pelz) April 5, 2024, 4:41 p.m. UTC | #2
Hello Aaron.  Because PO4A uses different command-line options and we
apparently need to provide a config file, IMHO this patch should wait
until [0] is settled.

Regards,
Florian

[0] https://github.com/mquinson/po4a/issues/490
diff mbox series

Patch

diff --git a/configure.ac b/configure.ac
index ecbd596a34..ad148f33b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -262,8 +262,7 @@  dnl Manual pages.
 AM_MISSING_PROG([HELP2MAN], [help2man])
 
 dnl Documentation translation.
-AM_MISSING_PROG([PO4A_TRANSLATE], [po4a-translate])
-AM_MISSING_PROG([PO4A_UPDATEPO], [po4a-updatepo])
+AM_MISSING_PROG([PO4A], [po4a])
 
 case "$storedir" in
   /gnu/store)
diff --git a/guix/self.scm b/guix/self.scm
index 19c6d08e01..e47f82e02f 100644
--- a/guix/self.scm
+++ b/guix/self.scm
@@ -317,7 +317,7 @@  (define build
           (define (translate-tmp-texi po source output)
             "Translate Texinfo file SOURCE using messages from PO, and write
 the result to OUTPUT."
-            (invoke #+(file-append po4a "/bin/po4a-translate")
+            (invoke #+(file-append po4a "/bin/po4a")
               "-M" "UTF-8" "-L" "UTF-8" "-k" "0" "-f" "texinfo"
               "-m" source "-p" po "-l" output))