diff mbox series

[bug#69620,rust-team,v3,1/9] gnu: Add rust-inlinable-string-0.1

Message ID 20240324152001.148236-3-aaron.covrig.us@ieee.org
State New
Headers show
Series Enables building of rust-rocket | expand

Commit Message

Aaron Covrig March 24, 2024, 3:19 p.m. UTC
* gnu/packages/crates-io.scm (rust-inlinable-string-0.1): Add variable
---
 gnu/packages/crates-io.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4eee577e59..ea8dcb5cec 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -42,6 +42,7 @@ 
 ;;; Copyright © 2024 Herman Rimm <herman@rimm.ee>
 ;;; Copyright © 2024 Tomas Volf <~@wolfsden.cz>
 ;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
+;;; Copyright © 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -32398,6 +32399,31 @@  (define-public rust-inline-c-macro-0.1
 writing and executing C code inside Rust.")
     (license license:bsd-3)))
 
+(define-public rust-inlinable-string-0.1
+  (package
+    (name "rust-inlinable-string")
+    (version "0.1.15")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "inlinable_string" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1ysjci8yfvxgf51z0ny2nnwhxrclhmb3vbngin8v4bznhr3ybyn8"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-serde" ,rust-serde-1))
+       #:cargo-development-inputs (("rust-serde-test" ,rust-serde-test-1))))
+    (home-page "https://github.com/fitzgen/inlinable_string")
+    (synopsis "Provides inline strings that avoid heap-allocation")
+    (description
+     "The @code{inlinable_string} crate provides the @code{InlinableString} type
+-- an owned, grow-able UTF-8 string that stores small strings inline and avoids
+heap-allocation -- and the @code{StringExt} trait which abstracts string
+operations over both @code{std::string::String} and @code{InlinableString} (or
+even your own custom string type)")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public rust-inotify-0.10
   (package
     (name "rust-inotify")