diff mbox series

[bug#69579] gnu: python-joblib: Update to 1.3.2.

Message ID 20240306093803.4725-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#69579] gnu: python-joblib: Update to 1.3.2. | expand

Commit Message

Nicolas Graves March 6, 2024, 9:38 a.m. UTC
* gnu/packages/python-xyz.scm (python-joblib): Update to 1.3.2.
[build-system]: Update to pyproject-build-system.
[arguments]
  <#:phases>: Remove check phase.
  <#:test-flags>: Keep former test flag.
[propagated-inputs]: Add python-psutil.

Change-Id: Ide110a19431b1d26e1d7dd8d1adc3b3f0f417749
---
 gnu/packages/python-xyz.scm | 22 ++++++++--------------
 1 file changed, 8 insertions(+), 14 deletions(-)

Comments

Vagrant Cascadian March 8, 2024, 8:29 p.m. UTC | #1
On 2024-03-06, Nicolas Graves wrote:
> * gnu/packages/python-xyz.scm (python-joblib): Update to 1.3.2.
> [build-system]: Update to pyproject-build-system.
> [arguments]
>   <#:phases>: Remove check phase.
>   <#:test-flags>: Keep former test flag.
> [propagated-inputs]: Add python-psutil.
>
> Change-Id: Ide110a19431b1d26e1d7dd8d1adc3b3f0f417749
> ---
>  gnu/packages/python-xyz.scm | 22 ++++++++--------------
>  1 file changed, 8 insertions(+), 14 deletions(-)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 46232d3c98..122dca6e4e 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -6169,26 +6169,20 @@ (define-public python-pystitcher
>  (define-public python-joblib
>    (package
>      (name "python-joblib")
> -    (version "1.1.1")
> +    (version "1.3.2")
>      (source (origin
>                (method url-fetch)
>                (uri (pypi-uri "joblib" version))
>                (sha256
>                 (base32
> -                "0019p280s2k941mihl67l7y6amwx86639xp3zvpsg1lmyish67rh"))))
> -    (build-system python-build-system)
> +                "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
> +    (build-system pyproject-build-system)
>      (arguments
> -     `(#:phases
> -       (modify-phases %standard-phases
> -         (replace 'check
> -           (lambda* (#:key tests? #:allow-other-keys)
> -             (when tests?
> -               (setenv "JOBLIB_MULTIPROCESSING" "0")
> -               (invoke "pytest" "-v" "joblib"
> -                       ;; We disable this test to avoid having to depend on ipython/jupyter
> -                       "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))))))
> -    (native-inputs
> -     (list python-pytest))
> +     (list
> +      #:test-flags  ; disabled to avoid having to depend on ipython/jupyter
> +      #~(list "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))
> +    (native-inputs (list python-pytest))
> +    (propagated-inputs (list python-psutil))
>      (home-page "https://joblib.readthedocs.io/")
>      (synopsis "Using Python functions as pipeline jobs")
>      (description
> -- 
> 2.41.0

I did a local test build, and tried to build the moderately large list
of dependents (~90 if I recall), which seems to fix some builds and
introduces some new failures, and some still fail in both cases...

with python-joblib 1.3.2 patch:

guix build: error: build of
`/gnu/store/1f7fjigxbran1bn1lwvy4v7vfdfz09rj-python-pingouin-0.5.2.drv',
`/gnu/store/4g2r98m4d5zkwvlgghdqgvnda8p5b8lf-tadbit-1.0.1-1.5c4c1dd.drv',
`/gnu/store/8gkvizln2kjpdjn4m89vws9xpj3f62dw-python-scikit-allel-1.3.5.drv',
`/gnu/store/cm2dr4npm0bn9w7xiyrfizcq097laibw-python-pyts-0.13.0.drv',
`/gnu/store/h5l1cymbzrz2havw6ygn0gafxwvf5k9m-python-matplotlib-documentation-3.8.2.drv',
`/gnu/store/ijg5hbhwj3h89bzh0n9l8zrg595bnscz-python-openturns-1.21.3.drv',
`/gnu/store/n0f7flida4sag8ifsvmczg4r33r07ry8-python-pytorch-geometric-2.4.0.drv',
`/gnu/store/yl5rndzgfprfr0lpcrhdwmvix61zyccr-python-poliastro-0.17.0.drv'
failed

without python-joblib 1.3.2 patch:

guix build: error: build of
`/gnu/store/rhd4p3n7ih0apdbqn552dvgf67ljmj5s-python-pingouin-0.5.2.drv',
`/gnu/store/mdcf9g773mz96397fpy7hbhj624svdai-python-scikit-allel-1.3.5.drv',
`/gnu/store/7b2px2nkw02i62zbc8izh5wlc08bvpp3-python-matplotlib-documentation-3.5.2.drv',
`/gnu/store/36hdl27cw8gb9s7alf3ginmqk40lzjzm-python-xgboost-1.5.2.drv',
`/gnu/store/jja4pvcnsxd63mb6jxlilkyjjf0a524m-python-hicexplorer-3.7.2.drv',
`/gnu/store/mqzg965f7qhiz1rk93yqlq5p6p93h30j-python-episcanpy-0.4.0.drv',
`/gnu/store/r4bx6mx0bkhk25zq4g91wma0s5ll016q-python-multivelo-0.1.2.drv',
`/gnu/store/wrpm94hkilphkznif8nzan8gblaflrqp-python-ikarus-0.0.2.drv' failed
Nicolas Graves March 8, 2024, 10:20 p.m. UTC | #2
On 2024-03-08 12:29, Vagrant Cascadian wrote:

> On 2024-03-06, Nicolas Graves wrote:
>> * gnu/packages/python-xyz.scm (python-joblib): Update to 1.3.2.
>> [build-system]: Update to pyproject-build-system.
>> [arguments]
>>   <#:phases>: Remove check phase.
>>   <#:test-flags>: Keep former test flag.
>> [propagated-inputs]: Add python-psutil.
>>
>> Change-Id: Ide110a19431b1d26e1d7dd8d1adc3b3f0f417749
>> ---
>>  gnu/packages/python-xyz.scm | 22 ++++++++--------------
>>  1 file changed, 8 insertions(+), 14 deletions(-)
>>
>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>> index 46232d3c98..122dca6e4e 100644
>> --- a/gnu/packages/python-xyz.scm
>> +++ b/gnu/packages/python-xyz.scm
>> @@ -6169,26 +6169,20 @@ (define-public python-pystitcher
>>  (define-public python-joblib
>>    (package
>>      (name "python-joblib")
>> -    (version "1.1.1")
>> +    (version "1.3.2")
>>      (source (origin
>>                (method url-fetch)
>>                (uri (pypi-uri "joblib" version))
>>                (sha256
>>                 (base32
>> -                "0019p280s2k941mihl67l7y6amwx86639xp3zvpsg1lmyish67rh"))))
>> -    (build-system python-build-system)
>> +                "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
>> +    (build-system pyproject-build-system)
>>      (arguments
>> -     `(#:phases
>> -       (modify-phases %standard-phases
>> -         (replace 'check
>> -           (lambda* (#:key tests? #:allow-other-keys)
>> -             (when tests?
>> -               (setenv "JOBLIB_MULTIPROCESSING" "0")
>> -               (invoke "pytest" "-v" "joblib"
>> -                       ;; We disable this test to avoid having to depend on ipython/jupyter
>> -                       "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))))))
>> -    (native-inputs
>> -     (list python-pytest))
>> +     (list
>> +      #:test-flags  ; disabled to avoid having to depend on ipython/jupyter
>> +      #~(list "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))
>> +    (native-inputs (list python-pytest))
>> +    (propagated-inputs (list python-psutil))
>>      (home-page "https://joblib.readthedocs.io/")
>>      (synopsis "Using Python functions as pipeline jobs")
>>      (description
>> -- 
>> 2.41.0
>
> I did a local test build, and tried to build the moderately large list
> of dependents (~90 if I recall), which seems to fix some builds and
> introduces some new failures, and some still fail in both cases...
>
> with python-joblib 1.3.2 patch:
>
> guix build: error: build of
> `/gnu/store/1f7fjigxbran1bn1lwvy4v7vfdfz09rj-python-pingouin-0.5.2.drv',
> `/gnu/store/4g2r98m4d5zkwvlgghdqgvnda8p5b8lf-tadbit-1.0.1-1.5c4c1dd.drv',
> `/gnu/store/8gkvizln2kjpdjn4m89vws9xpj3f62dw-python-scikit-allel-1.3.5.drv',
> `/gnu/store/cm2dr4npm0bn9w7xiyrfizcq097laibw-python-pyts-0.13.0.drv',
> `/gnu/store/h5l1cymbzrz2havw6ygn0gafxwvf5k9m-python-matplotlib-documentation-3.8.2.drv',
> `/gnu/store/ijg5hbhwj3h89bzh0n9l8zrg595bnscz-python-openturns-1.21.3.drv',
> `/gnu/store/n0f7flida4sag8ifsvmczg4r33r07ry8-python-pytorch-geometric-2.4.0.drv',
> `/gnu/store/yl5rndzgfprfr0lpcrhdwmvix61zyccr-python-poliastro-0.17.0.drv'
> failed
>
> without python-joblib 1.3.2 patch:
>
> guix build: error: build of
> `/gnu/store/rhd4p3n7ih0apdbqn552dvgf67ljmj5s-python-pingouin-0.5.2.drv',
> `/gnu/store/mdcf9g773mz96397fpy7hbhj624svdai-python-scikit-allel-1.3.5.drv',
> `/gnu/store/7b2px2nkw02i62zbc8izh5wlc08bvpp3-python-matplotlib-documentation-3.5.2.drv',
> `/gnu/store/36hdl27cw8gb9s7alf3ginmqk40lzjzm-python-xgboost-1.5.2.drv',
> `/gnu/store/jja4pvcnsxd63mb6jxlilkyjjf0a524m-python-hicexplorer-3.7.2.drv',
> `/gnu/store/mqzg965f7qhiz1rk93yqlq5p6p93h30j-python-episcanpy-0.4.0.drv',
> `/gnu/store/r4bx6mx0bkhk25zq4g91wma0s5ll016q-python-multivelo-0.1.2.drv',
> `/gnu/store/wrpm94hkilphkznif8nzan8gblaflrqp-python-ikarus-0.0.2.drv' failed

Thanks for this, I'll investigate further.
Nicolas Graves March 13, 2024, 6:46 a.m. UTC | #3
On 2024-03-08 12:29, Vagrant Cascadian wrote:

> On 2024-03-06, Nicolas Graves wrote:
>> * gnu/packages/python-xyz.scm (python-joblib): Update to 1.3.2.
>> [build-system]: Update to pyproject-build-system.
>> [arguments]
>>   <#:phases>: Remove check phase.
>>   <#:test-flags>: Keep former test flag.
>> [propagated-inputs]: Add python-psutil.
>>
>> Change-Id: Ide110a19431b1d26e1d7dd8d1adc3b3f0f417749
>> ---
>>  gnu/packages/python-xyz.scm | 22 ++++++++--------------
>>  1 file changed, 8 insertions(+), 14 deletions(-)
>>
>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>> index 46232d3c98..122dca6e4e 100644
>> --- a/gnu/packages/python-xyz.scm
>> +++ b/gnu/packages/python-xyz.scm
>> @@ -6169,26 +6169,20 @@ (define-public python-pystitcher
>>  (define-public python-joblib
>>    (package
>>      (name "python-joblib")
>> -    (version "1.1.1")
>> +    (version "1.3.2")
>>      (source (origin
>>                (method url-fetch)
>>                (uri (pypi-uri "joblib" version))
>>                (sha256
>>                 (base32
>> -                "0019p280s2k941mihl67l7y6amwx86639xp3zvpsg1lmyish67rh"))))
>> -    (build-system python-build-system)
>> +                "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
>> +    (build-system pyproject-build-system)
>>      (arguments
>> -     `(#:phases
>> -       (modify-phases %standard-phases
>> -         (replace 'check
>> -           (lambda* (#:key tests? #:allow-other-keys)
>> -             (when tests?
>> -               (setenv "JOBLIB_MULTIPROCESSING" "0")
>> -               (invoke "pytest" "-v" "joblib"
>> -                       ;; We disable this test to avoid having to depend on ipython/jupyter
>> -                       "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))))))
>> -    (native-inputs
>> -     (list python-pytest))
>> +     (list
>> +      #:test-flags  ; disabled to avoid having to depend on ipython/jupyter
>> +      #~(list "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))
>> +    (native-inputs (list python-pytest))
>> +    (propagated-inputs (list python-psutil))
>>      (home-page "https://joblib.readthedocs.io/")
>>      (synopsis "Using Python functions as pipeline jobs")
>>      (description
>> -- 
>> 2.41.0
>
> I did a local test build, and tried to build the moderately large list
> of dependents (~90 if I recall), which seems to fix some builds and
> introduces some new failures, and some still fail in both cases...

For the packages that were failing before but not after applying the
patch, I don't see why they're relevant, so I'll ignore them here.

For the following packages, they fail in both cases and are not about
this patch, I do not consider them in the review:

> `/gnu/store/1f7fjigxbran1bn1lwvy4v7vfdfz09rj-python-pingouin-0.5.2.drv',
> `/gnu/store/8gkvizln2kjpdjn4m89vws9xpj3f62dw-python-scikit-allel-1.3.5.drv',

The following packages build properly on my side, so they either failed
because of some determinism or system issue, or were simply fixes in the
meantime :

> `/gnu/store/ijg5hbhwj3h89bzh0n9l8zrg595bnscz-python-openturns-1.21.3.drv',
> `/gnu/store/cm2dr4npm0bn9w7xiyrfizcq097laibw-python-pyts-0.13.0.drv',
> `/gnu/store/n0f7flida4sag8ifsvmczg4r33r07ry8-python-pytorch-geometric-2.4.0.drv',
> `/gnu/store/yl5rndzgfprfr0lpcrhdwmvix61zyccr-python-poliastro-0.17.0.drv'

Now there are still some relevant failures, but they seem to come from
changes in the meantime, you probably have some patches differing
between both tries, since python-matplotlib-documentation is not the
same version between both.

> `/gnu/store/4g2r98m4d5zkwvlgghdqgvnda8p5b8lf-tadbit-1.0.1-1.5c4c1dd.drv',

>> File "/gnu/store/vkj58jsab13ybc871aiqrxdkmi54ijxn-tadbit-1.0.1-1.5c4c1dd/lib/python3.10/site-packages/pytadbit/mapping/restriction_enzymes.py", line 12, in <module>
>>    from scipy.stats import binom_test

The error in tadbit I get actually comes from scipy update. This should
be fixed in a tadbit-specific patch or update, rather than here.
    
> `/gnu/store/h5l1cymbzrz2havw6ygn0gafxwvf5k9m-python-matplotlib-documentation-3.8.2.drv',

This one is about missing python-pyyaml and unsubmitted python-sphinx-design
packages at least. This should be fixed in a matplotlib-specific patch,
rather than here.

I've also tried to rebuild all dependent packages on
447e9c96259e8fa15a828de9b2dd3400e2ffafe6, I also see the following
failures among dependents :
- music21@7.1.0 : missing dependency on numpy, to fix in a dedicated
patch 
- python-orange-canvas-core : probably some qt version mismatch here, to
fix in a dedicated patch

All in all, I don't see a precise reason why this patch is responsible
for any of the failures.
Christopher Baines March 13, 2024, 12:39 p.m. UTC | #4
Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

> On 2024-03-08 12:29, Vagrant Cascadian wrote:
>
>> On 2024-03-06, Nicolas Graves wrote:
>>> * gnu/packages/python-xyz.scm (python-joblib): Update to 1.3.2.
>>> [build-system]: Update to pyproject-build-system.
>>> [arguments]
>>>   <#:phases>: Remove check phase.
>>>   <#:test-flags>: Keep former test flag.
>>> [propagated-inputs]: Add python-psutil.
>>>
>>> Change-Id: Ide110a19431b1d26e1d7dd8d1adc3b3f0f417749
>>> ---
>>>  gnu/packages/python-xyz.scm | 22 ++++++++--------------
>>>  1 file changed, 8 insertions(+), 14 deletions(-)
>>>
>>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>>> index 46232d3c98..122dca6e4e 100644
>>> --- a/gnu/packages/python-xyz.scm
>>> +++ b/gnu/packages/python-xyz.scm
>>> @@ -6169,26 +6169,20 @@ (define-public python-pystitcher
>>>  (define-public python-joblib
>>>    (package
>>>      (name "python-joblib")
>>> -    (version "1.1.1")
>>> +    (version "1.3.2")
>>>      (source (origin
>>>                (method url-fetch)
>>>                (uri (pypi-uri "joblib" version))
>>>                (sha256
>>>                 (base32
>>> -                "0019p280s2k941mihl67l7y6amwx86639xp3zvpsg1lmyish67rh"))))
>>> -    (build-system python-build-system)
>>> +                "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
>>> +    (build-system pyproject-build-system)
>>>      (arguments
>>> -     `(#:phases
>>> -       (modify-phases %standard-phases
>>> -         (replace 'check
>>> -           (lambda* (#:key tests? #:allow-other-keys)
>>> -             (when tests?
>>> -               (setenv "JOBLIB_MULTIPROCESSING" "0")

We should look at why this was added, and whether it should be kept.

> All in all, I don't see a precise reason why this patch is responsible
> for any of the failures.

QA seems to agree at least, there looks to be some issues, but this
change seems to not make the situation worse at least.
Nicolas Graves March 13, 2024, 1:16 p.m. UTC | #5
On 2024-03-13 12:39, Christopher Baines wrote:

> Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:
>
>> On 2024-03-08 12:29, Vagrant Cascadian wrote:
>>
>>> On 2024-03-06, Nicolas Graves wrote:
>>>> * gnu/packages/python-xyz.scm (python-joblib): Update to 1.3.2.
>>>> [build-system]: Update to pyproject-build-system.
>>>> [arguments]
>>>>   <#:phases>: Remove check phase.
>>>>   <#:test-flags>: Keep former test flag.
>>>> [propagated-inputs]: Add python-psutil.
>>>>
>>>> Change-Id: Ide110a19431b1d26e1d7dd8d1adc3b3f0f417749
>>>> ---
>>>>  gnu/packages/python-xyz.scm | 22 ++++++++--------------
>>>>  1 file changed, 8 insertions(+), 14 deletions(-)
>>>>
>>>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>>>> index 46232d3c98..122dca6e4e 100644
>>>> --- a/gnu/packages/python-xyz.scm
>>>> +++ b/gnu/packages/python-xyz.scm
>>>> @@ -6169,26 +6169,20 @@ (define-public python-pystitcher
>>>>  (define-public python-joblib
>>>>    (package
>>>>      (name "python-joblib")
>>>> -    (version "1.1.1")
>>>> +    (version "1.3.2")
>>>>      (source (origin
>>>>                (method url-fetch)
>>>>                (uri (pypi-uri "joblib" version))
>>>>                (sha256
>>>>                 (base32
>>>> -                "0019p280s2k941mihl67l7y6amwx86639xp3zvpsg1lmyish67rh"))))
>>>> -    (build-system python-build-system)
>>>> +                "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
>>>> +    (build-system pyproject-build-system)
>>>>      (arguments
>>>> -     `(#:phases
>>>> -       (modify-phases %standard-phases
>>>> -         (replace 'check
>>>> -           (lambda* (#:key tests? #:allow-other-keys)
>>>> -             (when tests?
>>>> -               (setenv "JOBLIB_MULTIPROCESSING" "0")
>
> We should look at why this was added, and whether it should be kept.

This is only present in the check phase, not in the final package. I
guess when we switched to the pyproject-build-system or simply updated,
this simply wasn't necessary anymore.

Since tests were consistantly (--check) passing, I do not see the need
to investigate that.

>
>> All in all, I don't see a precise reason why this patch is responsible
>> for any of the failures.
>
> QA seems to agree at least, there looks to be some issues, but this
> change seems to not make the situation worse at least.
Nicolas Graves March 15, 2024, 7:15 p.m. UTC | #6
On 2024-03-13 14:16, Nicolas Graves wrote:

> On 2024-03-13 12:39, Christopher Baines wrote:
>
>> Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:
>>
>>> On 2024-03-08 12:29, Vagrant Cascadian wrote:
>>>
>>>> On 2024-03-06, Nicolas Graves wrote:
>>>>> * gnu/packages/python-xyz.scm (python-joblib): Update to 1.3.2.
>>>>> [build-system]: Update to pyproject-build-system.
>>>>> [arguments]
>>>>>   <#:phases>: Remove check phase.
>>>>>   <#:test-flags>: Keep former test flag.
>>>>> [propagated-inputs]: Add python-psutil.
>>>>>
>>>>> Change-Id: Ide110a19431b1d26e1d7dd8d1adc3b3f0f417749
>>>>> ---
>>>>>  gnu/packages/python-xyz.scm | 22 ++++++++--------------
>>>>>  1 file changed, 8 insertions(+), 14 deletions(-)
>>>>>
>>>>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>>>>> index 46232d3c98..122dca6e4e 100644
>>>>> --- a/gnu/packages/python-xyz.scm
>>>>> +++ b/gnu/packages/python-xyz.scm
>>>>> @@ -6169,26 +6169,20 @@ (define-public python-pystitcher
>>>>>  (define-public python-joblib
>>>>>    (package
>>>>>      (name "python-joblib")
>>>>> -    (version "1.1.1")
>>>>> +    (version "1.3.2")
>>>>>      (source (origin
>>>>>                (method url-fetch)
>>>>>                (uri (pypi-uri "joblib" version))
>>>>>                (sha256
>>>>>                 (base32
>>>>> -                "0019p280s2k941mihl67l7y6amwx86639xp3zvpsg1lmyish67rh"))))
>>>>> -    (build-system python-build-system)
>>>>> +                "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
>>>>> +    (build-system pyproject-build-system)
>>>>>      (arguments
>>>>> -     `(#:phases
>>>>> -       (modify-phases %standard-phases
>>>>> -         (replace 'check
>>>>> -           (lambda* (#:key tests? #:allow-other-keys)
>>>>> -             (when tests?
>>>>> -               (setenv "JOBLIB_MULTIPROCESSING" "0")
>>
>> We should look at why this was added, and whether it should be kept.
>
> This is only present in the check phase, not in the final package. I
> guess when we switched to the pyproject-build-system or simply updated,
> this simply wasn't necessary anymore.
>
> Since tests were consistantly (--check) passing, I do not see the need
> to investigate that.

Christopher, is that good enough of an explanation to get this one
merged or would you rather have mpe really investigating it?

>
>>
>>> All in all, I don't see a precise reason why this patch is responsible
>>> for any of the failures.
>>
>> QA seems to agree at least, there looks to be some issues, but this
>> change seems to not make the situation worse at least.
Christopher Baines March 16, 2024, 12:08 p.m. UTC | #7
Nicolas Graves <ngraves@ngraves.fr> writes:

> On 2024-03-13 14:16, Nicolas Graves wrote:
>
>> On 2024-03-13 12:39, Christopher Baines wrote:
>>
>>> Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:
>>>
>>>> On 2024-03-08 12:29, Vagrant Cascadian wrote:
>>>>
>>>>> On 2024-03-06, Nicolas Graves wrote:
>>>>>> * gnu/packages/python-xyz.scm (python-joblib): Update to 1.3.2.
>>>>>> [build-system]: Update to pyproject-build-system.
>>>>>> [arguments]
>>>>>>   <#:phases>: Remove check phase.
>>>>>>   <#:test-flags>: Keep former test flag.
>>>>>> [propagated-inputs]: Add python-psutil.
>>>>>>
>>>>>> Change-Id: Ide110a19431b1d26e1d7dd8d1adc3b3f0f417749
>>>>>> ---
>>>>>>  gnu/packages/python-xyz.scm | 22 ++++++++--------------
>>>>>>  1 file changed, 8 insertions(+), 14 deletions(-)
>>>>>>
>>>>>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>>>>>> index 46232d3c98..122dca6e4e 100644
>>>>>> --- a/gnu/packages/python-xyz.scm
>>>>>> +++ b/gnu/packages/python-xyz.scm
>>>>>> @@ -6169,26 +6169,20 @@ (define-public python-pystitcher
>>>>>>  (define-public python-joblib
>>>>>>    (package
>>>>>>      (name "python-joblib")
>>>>>> -    (version "1.1.1")
>>>>>> +    (version "1.3.2")
>>>>>>      (source (origin
>>>>>>                (method url-fetch)
>>>>>>                (uri (pypi-uri "joblib" version))
>>>>>>                (sha256
>>>>>>                 (base32
>>>>>> -                "0019p280s2k941mihl67l7y6amwx86639xp3zvpsg1lmyish67rh"))))
>>>>>> -    (build-system python-build-system)
>>>>>> +                "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
>>>>>> +    (build-system pyproject-build-system)
>>>>>>      (arguments
>>>>>> -     `(#:phases
>>>>>> -       (modify-phases %standard-phases
>>>>>> -         (replace 'check
>>>>>> -           (lambda* (#:key tests? #:allow-other-keys)
>>>>>> -             (when tests?
>>>>>> -               (setenv "JOBLIB_MULTIPROCESSING" "0")
>>>
>>> We should look at why this was added, and whether it should be kept.
>>
>> This is only present in the check phase, not in the final package. I
>> guess when we switched to the pyproject-build-system or simply updated,
>> this simply wasn't necessary anymore.
>>
>> Since tests were consistantly (--check) passing, I do not see the need
>> to investigate that.
>
> Christopher, is that good enough of an explanation to get this one
> merged or would you rather have mpe really investigating it?

I think it's good to check the commit message at least:

  https://git.savannah.gnu.org/cgit/guix.git/commit/?id=a41f93c39d03143ce9007ad278a04fa30498bc0b

Given that there's no reasoning there for this change, I think it's fine
to remove.
Christopher Baines March 20, 2024, 5:45 p.m. UTC | #8
Christopher Baines <mail@cbaines.net> writes:

> Nicolas Graves <ngraves@ngraves.fr> writes:
>
>> On 2024-03-13 14:16, Nicolas Graves wrote:
>>
>>> On 2024-03-13 12:39, Christopher Baines wrote:
>>>
>>>> Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:
>>>>
>>>>> On 2024-03-08 12:29, Vagrant Cascadian wrote:
>>>>>
>>>>>> On 2024-03-06, Nicolas Graves wrote:
>>>>>>> * gnu/packages/python-xyz.scm (python-joblib): Update to 1.3.2.
>>>>>>> [build-system]: Update to pyproject-build-system.
>>>>>>> [arguments]
>>>>>>>   <#:phases>: Remove check phase.
>>>>>>>   <#:test-flags>: Keep former test flag.
>>>>>>> [propagated-inputs]: Add python-psutil.
>>>>>>>
>>>>>>> Change-Id: Ide110a19431b1d26e1d7dd8d1adc3b3f0f417749
>>>>>>> ---
>>>>>>>  gnu/packages/python-xyz.scm | 22 ++++++++--------------
>>>>>>>  1 file changed, 8 insertions(+), 14 deletions(-)
>>>>>>>
>>>>>>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>>>>>>> index 46232d3c98..122dca6e4e 100644
>>>>>>> --- a/gnu/packages/python-xyz.scm
>>>>>>> +++ b/gnu/packages/python-xyz.scm
>>>>>>> @@ -6169,26 +6169,20 @@ (define-public python-pystitcher
>>>>>>>  (define-public python-joblib
>>>>>>>    (package
>>>>>>>      (name "python-joblib")
>>>>>>> -    (version "1.1.1")
>>>>>>> +    (version "1.3.2")
>>>>>>>      (source (origin
>>>>>>>                (method url-fetch)
>>>>>>>                (uri (pypi-uri "joblib" version))
>>>>>>>                (sha256
>>>>>>>                 (base32
>>>>>>> -                "0019p280s2k941mihl67l7y6amwx86639xp3zvpsg1lmyish67rh"))))
>>>>>>> -    (build-system python-build-system)
>>>>>>> +                "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
>>>>>>> +    (build-system pyproject-build-system)
>>>>>>>      (arguments
>>>>>>> -     `(#:phases
>>>>>>> -       (modify-phases %standard-phases
>>>>>>> -         (replace 'check
>>>>>>> -           (lambda* (#:key tests? #:allow-other-keys)
>>>>>>> -             (when tests?
>>>>>>> -               (setenv "JOBLIB_MULTIPROCESSING" "0")
>>>>
>>>> We should look at why this was added, and whether it should be kept.
>>>
>>> This is only present in the check phase, not in the final package. I
>>> guess when we switched to the pyproject-build-system or simply updated,
>>> this simply wasn't necessary anymore.
>>>
>>> Since tests were consistantly (--check) passing, I do not see the need
>>> to investigate that.
>>
>> Christopher, is that good enough of an explanation to get this one
>> merged or would you rather have mpe really investigating it?
>
> I think it's good to check the commit message at least:
>
>   https://git.savannah.gnu.org/cgit/guix.git/commit/?id=a41f93c39d03143ce9007ad278a04fa30498bc0b
>
> Given that there's no reasoning there for this change, I think it's fine
> to remove.

I've gone ahead and pushed this to master as
a24aa227f72544ae4b95510c62f968d219148efc.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 46232d3c98..122dca6e4e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6169,26 +6169,20 @@  (define-public python-pystitcher
 (define-public python-joblib
   (package
     (name "python-joblib")
-    (version "1.1.1")
+    (version "1.3.2")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "joblib" version))
               (sha256
                (base32
-                "0019p280s2k941mihl67l7y6amwx86639xp3zvpsg1lmyish67rh"))))
-    (build-system python-build-system)
+                "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (setenv "JOBLIB_MULTIPROCESSING" "0")
-               (invoke "pytest" "-v" "joblib"
-                       ;; We disable this test to avoid having to depend on ipython/jupyter
-                       "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))))))
-    (native-inputs
-     (list python-pytest))
+     (list
+      #:test-flags  ; disabled to avoid having to depend on ipython/jupyter
+      #~(list "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))
+    (native-inputs (list python-pytest))
+    (propagated-inputs (list python-psutil))
     (home-page "https://joblib.readthedocs.io/")
     (synopsis "Using Python functions as pipeline jobs")
     (description