diff mbox series

[bug#69560] gnu: combinatorial-blas: Fix build failure.

Message ID 20240305091031.26702-1-romain.garbage@inria.fr
State New
Headers show
Series [bug#69560] gnu: combinatorial-blas: Fix build failure. | expand

Commit Message

Romain GARBAGE March 5, 2024, 9:10 a.m. UTC
* gnu/packages/maths.scm (combinatorial-blas): Add new phase.

Change-Id: Ifefb2b17e6758547d38290753a7cd338032a6abb
---
 gnu/packages/maths.scm | 6 ++++++
 1 file changed, 6 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 47070ded15..0c5aa63dda 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8088,6 +8088,12 @@  (define-public combinatorial-blas
        #:parallel-tests? #f             ;tests use 'mpiexec -n4'
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'fix-tests
+           (lambda _
+             ;; remove failing tests (SIGFPE and SIGSEGV)
+             (substitute* "ReleaseTests/CMakeLists.txt"
+               (("^.*SpAsgnTest.*$") "")
+               (("^.*IndexingTest.*$") ""))))
          (add-before 'check 'mpi-setup
            ,%openmpi-setup)
          (add-before 'check 'test-setup